CVE-2017-6889
An integer overflow error within the "foveon_load_camf()" function (dcraw_foveon.c) in LibRaw...
An integer overflow error within the "foveon_load_camf()" function (dcraw_foveon.c) in LibRaw-demosaic-pack-GPL2 before 0.18.2 can be exploited to cause a heap-based buffer overflow.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
An integer overflow error within the "foveon_load_camf()" function (dcraw_foveon.c) in LibRaw-demosaic-pack-GPL2 before 0.18.2 can be exploited to cause a heap-based buffer overflow.
- Record
CVE-2017-6889- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-190
- Updated
- 2026-11-02
CVE List No score
An integer overflow error within the "foveon_load_camf()" function (dcraw_foveon.c) in LibRaw-demosaic-pack-GPL2 before 0.18.2 can be exploited to cause a heap-based buffer overflow.
- Record
CVE-2017-6889- Updated
- 2026-11-02
EUVDEUVD-2017-15943 No score
An integer overflow error within the "foveon_load_camf()" function (dcraw_foveon.c) in LibRaw-demosaic-pack-GPL2 before 0.18.2 can be exploited to cause a heap-based buffer overflow.
- Record
EUVD-2017-15943- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hh27-7rq7-g8w3
9.8
An integer overflow error within the "foveon_load_camf()" function (dcraw_foveon.c) in LibRaw...
An integer overflow error within the "foveon_load_camf()" function (dcraw_foveon.c) in LibRaw-demosaic-pack-GPL2 before 0.18.2 can be exploited to cause a heap-based buffer overflow.
- Record
GHSA-hh27-7rq7-g8w3- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSV
9.8
An integer overflow error within the "foveon_load_camf()" function (dcraw_foveon.c) in LibRaw-demosaic-pack-GPL2 before 0.18.2 can be exploited to cause a heap-based buffer overflow.
- Record
CVE-2017-6889- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0223 No score
Updated libraw packages fix security vulnerabilities
A memory corruption in parse_tiff_ifd() function (CVE-2017-6886).
A memory corruption via e.g. a specially crafted KDC file parse_tiff_ifd() (CVE-2017-6887).
An integer overflow error within the "foveon_load_camf()" function (CVE-2017-6889).
A boundary error within the "foveon_load_camf()" function (CVE-2017-6890).
- Record
MGASA-2017-0223- Updated
- 2026-11-02
OSVSUSE-SU-2017:2300-1 No score
Security update for libraw
This update for libraw fixes the following issues:
-
CVE-2015-3885: A specially crafted raw image file could have caused a Denial of Service through an integer overflow. (bsc#930683)
-
CVE-2015-8367: The function phase_one_correct() did not handle memory object initialization correctly, which may have caused some other problems. (bsc#957517)
-
CVE-2017-6886: memory corruption in parse_tiff_ifd() func (internal/dcraw_common.cpp) could lead to Denial of service (bsc#1039380)
-
CVE-2017-6889: integer overflow error within the 'foveon_load_camf()' function (dcraw_foveon.c) could lead to Denial of service (bsc#1039210)
-
CVE-2017-6890: boundary error within the 'foveon_load_camf()' function (dcraw_foveon.c) (bsc#1039209)
- Record
SUSE-SU-2017:2300-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
librawMageia:5 |
before 0.16.2-1.2.mga5 | 0.16.2-1.2.mga5 |
librawSUSE:Linux Enterprise Desktop 12 SP2 |
before 0.15.4-9.2 | 0.15.4-9.2 |
librawSUSE:Linux Enterprise Desktop 12 SP3 |
before 0.15.4-9.2 | 0.15.4-9.2 |
librawSUSE:Linux Enterprise Software Development Kit 12 SP2 |
before 0.15.4-9.2 | 0.15.4-9.2 |
librawSUSE:Linux Enterprise Software Development Kit 12 SP3 |
before 0.15.4-9.2 | 0.15.4-9.2 |
librawSUSE:Linux Enterprise Workstation Extension 12 SP2 |
before 0.15.4-9.2 | 0.15.4-9.2 |
librawSUSE:Linux Enterprise Workstation Extension 12 SP3 |
before 0.15.4-9.2 | 0.15.4-9.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-6889 is a critical vulnerability (CVSS 9.8) in Libraw Libraw-demosaic-pack-gpl2, published May 15, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.48%, the 73rd percentile. Fixed in libraw 0.16.2-1.2.mga5.
References
secuniaresearch.flexerasoftware.com/advisories/75000
github.com/LibRaw/LibRaw-demosaic-pack-GPL2/commit/194f592e205990ea8fce72b6c571c14350aca716
nvd.nist.gov/vuln/detail/CVE-2017-6889
github.com/advisories/GHSA-hh27-7rq7-g8w3
advisories.mageia.org/MGASA-2017-0223.html
bugs.mageia.org/show_bug.cgi?id=21004
Show 15 moreShow less
lists.opensuse.org/opensuse-updates/2017-05/msg00111.html
suse.com/support/update/announcement/2017/suse-su-20172300-1
bugzilla.suse.com/1039209
bugzilla.suse.com/1039210
bugzilla.suse.com/1039379
bugzilla.suse.com/1039380
bugzilla.suse.com/930683
bugzilla.suse.com/957517
suse.com/security/cve/CVE-2015-3885
suse.com/security/cve/CVE-2015-8367
suse.com/security/cve/CVE-2017-6886
suse.com/security/cve/CVE-2017-6887
suse.com/security/cve/CVE-2017-6889
suse.com/security/cve/CVE-2017-6890
suse.com/security/cve/CVE-2017-6899