Every CVE Search/ Get API key

CVE-2017-7309

MantisBT vulnerable to XSS through config_option parameter in adm_config_report.php

4.8 MediumFix available

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

57.3%Up 56.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 4.8

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

Record
CVE-2017-7309
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

Record
CVE-2017-7309
Updated
2026-11-02
EUVDEUVD-2017-16336 No score

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

Record
EUVD-2017-16336
Updated
2026-11-03
GitHub AdvisoriesGHSA-4w6c-3hcx-rfj5 4.8

MantisBT vulnerable to XSS through config_option parameter in adm_config_report.php

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

Record
GHSA-4w6c-3hcx-rfj5
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 4.8

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

Record
CVE-2017-7309
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-4w6c-3hcx-rfj5 4.8

MantisBT vulnerable to XSS through config_option parameter in adm_config_report.php

A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code (if CSP settings permit it) through a crafted 'config_option' parameter. This is fixed in 1.3.9, 2.1.3, and 2.2.3.

Record
GHSA-4w6c-3hcx-rfj5
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mantisbt/mantisbt
Packagist
before 1.3.9
1.3.9
mantisbt/mantisbt
Packagist
2.1.0 up to 2.1.3
2.1.3
mantisbt/mantisbt
Packagist
2.2.0 up to 2.2.3
2.2.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-7309 is a medium vulnerability (CVSS 4.8) in Mantisbt, published March 31, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 57.3%, the 99th percentile. Fixed in mantisbt/mantisbt 1.3.9.

References

Show 4 moreShow less
MoveEnter Open