Every CVE Search/ Get API key

CVE-2017-7476

Gnulib before 2017-04-26 has a heap-based buffer overflow with the TZ environment variable. The...

9.8 CriticalFix available

Gnulib before 2017-04-26 has a heap-based buffer overflow with the TZ environment variable. The error is in the save_abbr function in time_rz.c.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.65%Up 2.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Gnulib before 2017-04-26 has a heap-based buffer overflow with the TZ environment variable. The error is in the save_abbr function in time_rz.c.

Record
CVE-2017-7476
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Gnulib before 2017-04-26 has a heap-based buffer overflow with the TZ environment variable. The error is in the save_abbr function in time_rz.c.

Record
CVE-2017-7476
Updated
2026-11-02
EUVDEUVD-2017-16497 No score

Gnulib before 2017-04-26 has a heap-based buffer overflow with the TZ environment variable. The error is in the save_abbr function in time_rz.c.

Record
EUVD-2017-16497
Updated
2026-11-03
GitHub AdvisoriesGHSA-m9rq-c483-gg38 9.8

Gnulib before 2017-04-26 has a heap-based buffer overflow with the TZ environment variable. The...

Gnulib before 2017-04-26 has a heap-based buffer overflow with the TZ environment variable. The error is in the save_abbr function in time_rz.c.

Record
GHSA-m9rq-c483-gg38
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSVopenSUSE-SU-2024:10694-1 No score

coreutils-8.32-8.5 on GA media

These are all security issues fixed in the coreutils-8.32-8.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10694-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10735-1 No score

emacs-27.2-6.2 on GA media

These are all security issues fixed in the emacs-27.2-6.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10735-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
coreutils
openSUSE:Tumbleweed
before 8.32-8.5
8.32-8.5
emacs
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 27.2-6.2
27.2-6.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-7476 is a critical vulnerability (CVSS 9.8) in Gnulib, published May 2, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.65%, the 89th percentile. Fixed in coreutils 8.32-8.5.

References

Show 4 moreShow less
MoveEnter Open