Every CVE Search/ Get API key

CVE-2017-7491

Moodle Cross-Site Request Forgery (CSRF)

4.3 MediumFix available

In Moodle 2.x and 3.x, a CSRF attack is possible that allows attackers to change the "number of courses displayed in the course overview block" configuration setting.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.52%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 4.3

In Moodle 2.x and 3.x, a CSRF attack is possible that allows attackers to change the "number of courses displayed in the course overview block" configuration setting.

Record
CVE-2017-7491
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

In Moodle 2.x and 3.x, a CSRF attack is possible that allows attackers to change the "number of courses displayed in the course overview block" configuration setting.

Record
CVE-2017-7491
Updated
2026-11-02
EUVDEUVD-2022-2190 No score

In Moodle 2.x and 3.x, a CSRF attack is possible that allows attackers to change the "number of courses displayed in the course overview block" configuration setting.

Record
EUVD-2022-2190
Updated
2026-11-03
GitHub AdvisoriesGHSA-3hmr-948v-5qgq 4.3

Moodle Cross-Site Request Forgery (CSRF)

In Moodle 2.x and 3.x, a CSRF attack is possible that allows attackers to change the "number of courses displayed in the course overview block" configuration setting.

Record
GHSA-3hmr-948v-5qgq
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-352
Updated
2026-11-02
OSV 4.3

In Moodle 2.x and 3.x, a CSRF attack is possible that allows attackers to change the "number of courses displayed in the course overview block" configuration setting.

Record
CVE-2017-7491
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVGHSA-3hmr-948v-5qgq 4.3

Moodle Cross-Site Request Forgery (CSRF)

In Moodle 2.x and 3.x, a CSRF attack is possible that allows attackers to change the "number of courses displayed in the course overview block" configuration setting.

Record
GHSA-3hmr-948v-5qgq
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-352
Updated
2026-11-02
OSVUBUNTU-CVE-2017-7491 4.3

In Moodle 2.x and 3.x, a CSRF attack is possible that allows attackers to change the "number of courses displayed in the course overview block" configuration setting.

Record
UBUNTU-CVE-2017-7491
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
3.2 up to 3.2.3
3.2.3
moodle/moodle
Packagist
3.1 up to 3.1.6
3.1.6
moodle/moodle
Packagist
3.0 up to 3.0.10
3.0.10
moodle/moodle
Packagist
2.7 up to 2.7.20
2.7.20
moodle/moodle
Packagist
3.2 up to 3.2.3, plus listed versions
v3.2.0v3.2.0-betav3.2.0-rc1v3.2.0-rc2v3.2.0-rc3
Show 4 moreShow less
v3.2.0-rc4v3.2.0-rc5v3.2.1v3.2.2
3.2.3
moodle/moodle
Packagist
3.1 up to 3.1.6, plus listed versions
v3.1.0v3.1.0-betav3.1.0-rc1v3.1.0-rc2v3.1.1
Show 4 moreShow less
v3.1.2v3.1.3v3.1.4v3.1.5
3.1.6
moodle/moodle
Packagist
3.0 up to 3.0.10, plus listed versions
v3.0.0v3.0.0-betav3.0.0-rc1v3.0.0-rc2v3.0.0-rc3
Show 10 moreShow less
v3.0.0-rc4v3.0.1v3.0.2v3.0.3v3.0.4v3.0.5v3.0.6v3.0.7v3.0.8v3.0.9
3.0.10
moodle/moodle
Packagist
2.7 up to 2.7.20, plus listed versions
v2.7.0v2.7.0-betav2.7.0-rc1v2.7.0-rc2v2.7.1
Show 18 moreShow less
v2.7.10v2.7.11v2.7.12v2.7.13v2.7.14v2.7.15v2.7.16v2.7.17v2.7.18v2.7.19v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6v2.7.7v2.7.8v2.7.9
2.7.20
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-7491 is a medium vulnerability (CVSS 4.3) in Moodle, published May 15, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.52%, the 44th percentile. Fixed in moodle/moodle 3.2.3.

References

MoveEnter Open