CVE-2017-7524
tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password...
tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password in plaintext from client to server when generating HMAC.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password in plaintext from client to server when generating HMAC.
- Record
CVE-2017-7524- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-522
- Updated
- 2026-11-02
CVE List No score
tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password in plaintext from client to server when generating HMAC.
- Record
CVE-2017-7524- Weakness
- CWE-522
- Updated
- 2026-11-02
EUVDEUVD-2017-16541 No score
tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password in plaintext from client to server when generating HMAC.
- Record
EUVD-2017-16541- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-62m4-8mv5-x4gc
7.5
tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password...
tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password in plaintext from client to server when generating HMAC.
- Record
GHSA-62m4-8mv5-x4gc- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-522
- Updated
- 2026-11-02
OSV
7.5
tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password in plaintext from client to server when generating HMAC.
- Record
CVE-2017-7524- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-7524
7.5
tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password in plaintext from client to server when generating HMAC.
- Record
DEBIAN-CVE-2017-7524- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-7524
7.5
tpm2-tools versions before 1.1.1 are vulnerable to a password leak due to transmitting password in plaintext from client to server when generating HMAC.
- Record
UBUNTU-CVE-2017-7524- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11471-1 No score
tpm2.0-tools-5.1.1-3.2 on GA media
These are all security issues fixed in the tpm2.0-tools-5.1.1-3.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11471-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
tpm2-toolsDebian:12 |
before 2.1.0-1 | 2.1.0-1 |
tpm2-toolsDebian:13 |
before 2.1.0-1 | 2.1.0-1 |
tpm2-toolsDebian:14 |
before 2.1.0-1 | 2.1.0-1 |
tpm2.0-toolsopenSUSE:Tumbleweed |
before 5.1.1-3.2 | 5.1.1-3.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-7524 is a high vulnerability (CVSS 7.5) in Tpm 2.0 Tools Tpm2-tools, published June 27, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.24%, the 69th percentile. Fixed in tpm2-tools 2.1.0-1.
References
github.com/01org/tpm2.0-tools/commit/c5d72beaab1cbbbe68271f4bc4b6670d69985157
nvd.nist.gov/vuln/detail/CVE-2017-7524
github.com/advisories/GHSA-62m4-8mv5-x4gc
security-tracker.debian.org/tracker/CVE-2017-7524
ubuntu.com/security/CVE-2017-7524
cve.org/CVERecord?id=CVE-2017-7524
suse.com/security/cve/CVE-2017-7524
suse.com/security/cve/CVE-2021-3565