Every CVE Search/ Get API key

CVE-2017-7532

Moodle Improper Privilege Management

6.5 MediumFix available

In Moodle 3.x, course creators are able to change system default settings for courses.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.98%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

In Moodle 3.x, course creators are able to change system default settings for courses.

Record
CVE-2017-7532
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Weakness
CWE-269
Updated
2026-11-02
CVE List No score

In Moodle 3.x, course creators are able to change system default settings for courses.

Record
CVE-2017-7532
Updated
2026-11-02
EUVDEUVD-2022-4387 No score

In Moodle 3.x, course creators are able to change system default settings for courses.

Record
EUVD-2022-4387
Updated
2026-11-03
GitHub AdvisoriesGHSA-jjhx-5jff-rc8m 6.5

Moodle Improper Privilege Management

In Moodle 3.x, course creators are able to change system default settings for courses.

Record
GHSA-jjhx-5jff-rc8m
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-269
Updated
2026-11-02
OSV 6.5

In Moodle 3.x, course creators are able to change system default settings for courses.

Record
CVE-2017-7532
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-jjhx-5jff-rc8m 6.5

Moodle Improper Privilege Management

In Moodle 3.x, course creators are able to change system default settings for courses.

Record
GHSA-jjhx-5jff-rc8m
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-269
Updated
2026-11-02
OSVUBUNTU-CVE-2017-7532 6.5

In Moodle 3.x, course creators are able to change system default settings for courses.

Record
UBUNTU-CVE-2017-7532
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
3.3.0 to 3.3.0
3.3.1
moodle/moodle
Packagist
3.2.0 up to 3.2.4
3.2.4
moodle/moodle
Packagist
before 3.1.7
3.1.7
moodle/moodle
Packagist
3.3.0 up to 3.3.1, plus listed versions
v3.3.0
3.3.1
moodle/moodle
Packagist
3.2.0 up to 3.2.4, plus listed versions
v3.2.0v3.2.1v3.2.2v3.2.3
3.2.4
moodle/moodle
Packagist
before 3.1.7, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
3.1.7
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-7532 is a medium vulnerability (CVSS 6.5) in Moodle, published July 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.98%, the 62nd percentile. Fixed in moodle/moodle 3.3.1.

References

Show 4 moreShow less
This page doesn't list everything

Left out here: 76 versions. The JSON record has them.

MoveEnter Open