Every CVE Search/ Get API key

CVE-2017-7557

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API...

8.8 HighFix available

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.84%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.

Record
CVE-2017-7557
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-287, CWE-352
Updated
2026-11-02
CVE List No score

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.

Record
CVE-2017-7557
Weakness
CWE-287
Updated
2026-11-02
EUVDEUVD-2017-16564 No score

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.

Record
EUVD-2017-16564
Updated
2026-11-03
GitHub AdvisoriesGHSA-337m-69vh-g93q 8.8

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API...

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.

Record
GHSA-337m-69vh-g93q
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-287, CWE-352
Updated
2026-11-02
OSV 8.8

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.

Record
CVE-2017-7557
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-7557 8.8

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.

Record
DEBIAN-CVE-2017-7557
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2017-7557 8.8

dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.

Record
UBUNTU-CVE-2017-7557
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVSUSE-SU-2023:2760-1 No score

Security update for dnsdist

This update for dnsdist fixes the following issues:

  • update to 1.8.0

    • Implements dnsdist in SLE15 (jsc#PED-3402)
    • Security fix: fixes a possible record smugging with a crafted DNS query with trailing data (CVE-2018-14663, bsc#1114511)
  • update to 1.2.0 (bsc#1054799, bsc#1054802) This release also addresses two security issues of low severity, CVE-2016-7069 and CVE-2017-7557. The first issue can lead to a denial of service on 32-bit if a backend sends crafted answers, and the second to an alteration of dnsdist’s ACL if the API is enabled, writable and an authenticated user is tricked into visiting a crafted website.

Record
SUSE-SU-2023:2760-1
Updated
2026-11-02
OSVSUSE-SU-2023:2760-2 No score

Security update for dnsdist

This update for dnsdist fixes the following issues:

  • update to 1.8.0

    • Implements dnsdist in SLE15 (jsc#PED-3402)
    • Security fix: fixes a possible record smugging with a crafted DNS query with trailing data (CVE-2018-14663, bsc#1114511)
  • update to 1.2.0 (bsc#1054799, bsc#1054802) This release also addresses two security issues of low severity, CVE-2016-7069 and CVE-2017-7557. The first issue can lead to a denial of service on 32-bit if a backend sends crafted answers, and the second to an alteration of dnsdist’s ACL if the API is enabled, writable and an authenticated user is tricked into visiting a crafted website.

Record
SUSE-SU-2023:2760-2
Updated
2026-11-02
OSVSUSE-SU-2023:2777-1 No score

Security update for dnsdist

This update for dnsdist fixes the following issues:

  • Implements package 'dnsdist' with version 1.8.0 in SLE15. (jsc#PED-3402)
  • Downstream DNS resolver configuration should be chosen by the admin
  • Security fix: fixes a possible record smugging with a crafted DNS query with trailing data (CVE-2018-14663, bsc#1114511)
  • Security fix: There is an issue that can lead to a denial of service on 32-bit if a backend sends crafted answers. (CVE-2016-7069, bsc#1054799)
  • Security fix: Alteration of dnsdist's ACL if the API is enabled, writable and an authenticated user is tricked into visiting a crafted website. (CVE-2017-7557, bsc#1054799)
  • SNMP support, exporting statistics and sending traps
  • Preventing the packet cache from ageing responses when deployed in
  • Various DNSCrypt-related fixes and improvements, including automatic key rotation
Record
SUSE-SU-2023:2777-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
dnsdist
Debian:12
before 1.2.0-1
1.2.0-1
dnsdist
Debian:13
before 1.2.0-1
1.2.0-1
dnsdist
Debian:14
before 1.2.0-1
1.2.0-1
dnsdist
SUSE:Linux Enterprise Module for Basesystem 15 SP4
before 1.8.0-150400.9.3.1
1.8.0-150400.9.3.1
luajit
SUSE:Linux Enterprise Module for Basesystem 15 SP4
before 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
luajit
SUSE:Linux Enterprise Module for Package Hub 15 SP4
before 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
luajit
SUSE:Linux Enterprise Module for Package Hub 15 SP5
before 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
luajit
SUSE:Linux Enterprise Workstation Extension 15 SP4
before 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
luajit
SUSE:Linux Enterprise Workstation Extension 15 SP5
before 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
dnsdist
openSUSE:Leap 15.4
before 1.8.0-150400.9.3.1
1.8.0-150400.9.3.1
Show 11 moreShow less
Affected packages
PackageAffectedFixed
luajit
openSUSE:Leap 15.4
before 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
dnsdist
openSUSE:Leap 15.5
before 1.8.0-150400.9.3.1
1.8.0-150400.9.3.1
luajit
openSUSE:Leap 15.5
before 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
dnsdist
SUSE:Linux Enterprise Module for Basesystem 15 SP5
before 1.8.0-150400.9.3.1
1.8.0-150400.9.3.1
luajit
SUSE:Linux Enterprise Module for Basesystem 15 SP5
before 2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
2.1.0~beta3+git.1624618403.e9577376-150400.4.2.1
dnsdist
SUSE:Linux Enterprise Server 15 SP1-LTSS
before 1.8.0-150100.3.5.1
1.8.0-150100.3.5.1
dnsdist
SUSE:Linux Enterprise Server 15 SP2-LTSS
before 1.8.0-150100.3.5.1
1.8.0-150100.3.5.1
dnsdist
SUSE:Linux Enterprise Server 15 SP3-LTSS
before 1.8.0-150100.3.5.1
1.8.0-150100.3.5.1
dnsdist
SUSE:Linux Enterprise Server for SAP Applications 15 SP1
before 1.8.0-150100.3.5.1
1.8.0-150100.3.5.1
dnsdist
SUSE:Linux Enterprise Server for SAP Applications 15 SP2
before 1.8.0-150100.3.5.1
1.8.0-150100.3.5.1
dnsdist
Ubuntu:16.04:LTS
All versions, plus listed versions
1.0.0~alpha2-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-7557 is a high vulnerability (CVSS 8.8) in Powerdns Dnsdist, published August 22, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.84%, the 57th percentile. Fixed in dnsdist 1.2.0-1.

References

Show 11 moreShow less
MoveEnter Open