CVE-2017-7655
In Eclipse Mosquitto version from 1.0 to 1.4.15, a Null Dereference vulnerability was found in...
In Eclipse Mosquitto version from 1.0 to 1.4.15, a Null Dereference vulnerability was found in the Mosquitto library which could lead to crashes for those applications using the library.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
In Eclipse Mosquitto version from 1.0 to 1.4.15, a Null Dereference vulnerability was found in the Mosquitto library which could lead to crashes for those applications using the library.
- Record
CVE-2017-7655- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-476
- Updated
- 2026-11-02
CVE List No score
In Eclipse Mosquitto version from 1.0 to 1.4.15, a Null Dereference vulnerability was found in the Mosquitto library which could lead to crashes for those applications using the library.
- Record
CVE-2017-7655- Weakness
- CWE-476
- Updated
- 2026-11-02
EUVDEUVD-2017-16660 No score
In Eclipse Mosquitto version from 1.0 to 1.4.15, a Null Dereference vulnerability was found in the Mosquitto library which could lead to crashes for those applications using the library.
- Record
EUVD-2017-16660- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gg85-hmcj-cx9p
7.5
In Eclipse Mosquitto version from 1.0 to 1.4.15, a Null Dereference vulnerability was found in...
In Eclipse Mosquitto version from 1.0 to 1.4.15, a Null Dereference vulnerability was found in the Mosquitto library which could lead to crashes for those applications using the library.
- Record
GHSA-gg85-hmcj-cx9p- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
OSV
7.5
In Eclipse Mosquitto version from 1.0 to 1.4.15, a Null Dereference vulnerability was found in the Mosquitto library which could lead to crashes for those applications using the library.
- Record
CVE-2017-7655- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-7655
7.5
In Eclipse Mosquitto version from 1.0 to 1.4.15, a Null Dereference vulnerability was found in the Mosquitto library which could lead to crashes for those applications using the library.
- Record
DEBIAN-CVE-2017-7655- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-7655
7.5
In Eclipse Mosquitto version from 1.0 to 1.4.15, a Null Dereference vulnerability was found in the Mosquitto library which could lead to crashes for those applications using the library.
- Record
UBUNTU-CVE-2017-7655- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-4823-1 No score
mosquitto vulnerability
It was discovered that Mosquitto incorrectly handled certain inputs. A remote attacker could possibly use this issue to cause a denial of service.
- Record
USN-4823-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mosquittoDebian:12 |
before 1.5.4-1 | 1.5.4-1 |
mosquittoDebian:13 |
before 1.5.4-1 | 1.5.4-1 |
mosquittoDebian:14 |
before 1.5.4-1 | 1.5.4-1 |
mosquittoDebian:8 |
before 1.3.4-2+deb8u4, plus listed versions 1.3.4-21.3.4-2+deb8u11.3.4-2+deb8u21.3.4-2+deb8u3 |
1.3.4-2+deb8u4 |
mosquittoDebian:9 |
before 1.4.10-3+deb9u5, plus listed versions 1.4.10-31.4.10-3+deb9u11.4.10-3+deb9u21.4.10-3+deb9u31.4.10-3+deb9u4 |
1.4.10-3+deb9u5 |
mosquittoUbuntu:Pro:16.04:LTS |
before 1.4.8-1ubuntu0.16.04.7+esm1, plus listed versions 1.4.3-11.4.4-11.4.7-11.4.8-11.4.8-1build1 Show 7 moreShow less1.4.8-1ubuntu0.16.04.11.4.8-1ubuntu0.16.04.21.4.8-1ubuntu0.16.04.31.4.8-1ubuntu0.16.04.41.4.8-1ubuntu0.16.04.51.4.8-1ubuntu0.16.04.61.4.8-1ubuntu0.16.04.7 |
1.4.8-1ubuntu0.16.04.7+esm1 |
mosquittoUbuntu:Pro:18.04:LTS |
before 1.4.15-2ubuntu0.18.04.3+esm1, plus listed versions 1.4.12-11.4.14-11.4.14-21.4.14-2build11.4.15-1 Show 4 moreShow less1.4.15-21.4.15-2ubuntu0.18.04.11.4.15-2ubuntu0.18.04.21.4.15-2ubuntu0.18.04.3 |
1.4.15-2ubuntu0.18.04.3+esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-7655 is a high vulnerability (CVSS 7.5) in Eclipse Mosquitto, published March 27, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.76%, the 78th percentile. Fixed in mosquitto 1.5.4-1.