CVE-2017-7663
Apache OpenMeetings Cross-site Scripting vulnerability
Both global and Room chat are vulnerable to XSS attack in Apache OpenMeetings 3.2.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Both global and Room chat are vulnerable to XSS attack in Apache OpenMeetings 3.2.0.
- Record
CVE-2017-7663- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Both global and Room chat are vulnerable to XSS attack in Apache OpenMeetings 3.2.0.
- Record
CVE-2017-7663- Updated
- 2026-11-02
EUVDEUVD-2022-4854 No score
Both global and Room chat are vulnerable to XSS attack in Apache OpenMeetings 3.2.0.
- Record
EUVD-2022-4854- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pxj9-mw96-q634
6.1
Apache OpenMeetings Cross-site Scripting vulnerability
Both global and Room chat are vulnerable to XSS attack in Apache OpenMeetings 3.2.0. The issue is fixed in version 3.3.0.
- Record
GHSA-pxj9-mw96-q634- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-pxj9-mw96-q634
6.1
Apache OpenMeetings Cross-site Scripting vulnerability
Both global and Room chat are vulnerable to XSS attack in Apache OpenMeetings 3.2.0. The issue is fixed in version 3.3.0.
- Record
GHSA-pxj9-mw96-q634- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.openmeetings:openmeetings-parentMaven |
3.2.0 up to 3.3.0 | 3.3.0 |
org.apache.openmeetings:openmeetings-parentMaven |
3.2.0 up to 3.3.0, plus listed versions 3.2.1 |
3.3.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-7663 is a medium vulnerability (CVSS 6.1) in Apache Openmeetings, published July 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.67%, the 85th percentile. Fixed in org.apache.openmeetings:openmeetings-parent 3.3.0.