CVE-2017-7664
Apache OpenMeetings does not correctly validate uploaded XML documents
Uploaded XML documents were not correctly validated in Apache OpenMeetings 3.1.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
10.0
Uploaded XML documents were not correctly validated in Apache OpenMeetings 3.1.0.
- Record
CVE-2017-7664- CVSS 3.0
- 10.0 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-611
- Updated
- 2026-11-02
CVE List No score
Uploaded XML documents were not correctly validated in Apache OpenMeetings 3.1.0.
- Record
CVE-2017-7664- Updated
- 2026-11-02
EUVDEUVD-2022-2742 No score
Uploaded XML documents were not correctly validated in Apache OpenMeetings 3.1.0.
- Record
EUVD-2022-2742- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-67q3-gwww-pm4g
10.0
Apache OpenMeetings does not correctly validate uploaded XML documents
Uploaded XML documents were not correctly validated in Apache OpenMeetings 3.1.0. The issue is fixed in version 3.3.0.
- Record
GHSA-67q3-gwww-pm4g- CVSS 3.0
- 10.0 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H - Weakness
- CWE-611
- Updated
- 2026-11-02
OSV
10.0
Uploaded XML documents were not correctly validated in Apache OpenMeetings 3.1.0.
- Record
CVE-2017-7664- CVSS 3.0
- 10.0 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-67q3-gwww-pm4g
10.0
Apache OpenMeetings does not correctly validate uploaded XML documents
Uploaded XML documents were not correctly validated in Apache OpenMeetings 3.1.0. The issue is fixed in version 3.3.0.
- Record
GHSA-67q3-gwww-pm4g- CVSS 3.0
- 10.0 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H - Weakness
- CWE-611
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.openmeetings:openmeetings-parentMaven |
3.1.0 up to 3.3.0 | 3.3.0 |
org.apache.openmeetings:openmeetings-parentMaven |
3.1.0 up to 3.3.0, plus listed versions 3.1.23.1.33.1.43.1.53.2.03.2.1 |
3.3.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-7664 is a critical vulnerability (CVSS 10.0) in Apache Openmeetings, published July 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.35%, the 83rd percentile. Fixed in org.apache.openmeetings:openmeetings-parent 3.3.0.