Every CVE Search/ Get API key

CVE-2017-7665

Cross-site Scripting in Apache NiFi

6.1 MediumFix available

In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

3.51%Up 1.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.

Record
CVE-2017-7665
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.

Record
CVE-2017-7665
Updated
2026-11-02
EUVDEUVD-2022-4496 No score

In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.

Record
EUVD-2022-4496
Updated
2026-11-03
GitHub AdvisoriesGHSA-m5r7-w9v3-ghmx 6.1

Cross-site Scripting in Apache NiFi

In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.

Record
GHSA-m5r7-w9v3-ghmx
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.

Record
CVE-2017-7665
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-m5r7-w9v3-ghmx 6.1

Cross-site Scripting in Apache NiFi

In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.

Record
GHSA-m5r7-w9v3-ghmx
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.nifi:nifi
Maven
before 0.7.4
0.7.4
org.apache.nifi:nifi
Maven
1.0.0 up to 1.3.0
1.3.0
org.apache.nifi:nifi
Maven
before 0.7.4, plus listed versions
0.0.1-incubating0.0.2-incubating0.1.0-incubating0.2.0-incubating0.2.1
Show 11 moreShow less
0.3.00.4.00.4.10.5.00.5.10.6.00.6.10.7.00.7.10.7.20.7.3
0.7.4
org.apache.nifi:nifi
Maven
1.0.0 up to 1.3.0, plus listed versions
1.0.11.1.01.1.11.1.21.2.0
1.3.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-7665 is a medium vulnerability (CVSS 6.1) in Apache Nifi, published June 12, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.51%, the 89th percentile. Fixed in org.apache.nifi:nifi 0.7.4.

References

MoveEnter Open