Every CVE Search/ Get API key

CVE-2017-7666

Apache OpenMeetings vulnerable to Cross-Site Request Forgery

8.8 HighFix available

Apache OpenMeetings 1.0.0 is vulnerable to Cross-Site Request Forgery (CSRF) attacks, XSS attacks, click-jacking, and MIME based attacks.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.80%Down 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Apache OpenMeetings 1.0.0 is vulnerable to Cross-Site Request Forgery (CSRF) attacks, XSS attacks, click-jacking, and MIME based attacks.

Record
CVE-2017-7666
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-79, CWE-352
Updated
2026-11-02
CVE List No score

Apache OpenMeetings 1.0.0 is vulnerable to Cross-Site Request Forgery (CSRF) attacks, XSS attacks, click-jacking, and MIME based attacks.

Record
CVE-2017-7666
Updated
2026-11-02
EUVDEUVD-2022-4494 No score

Apache OpenMeetings 1.0.0 is vulnerable to Cross-Site Request Forgery (CSRF) attacks, XSS attacks, click-jacking, and MIME based attacks.

Record
EUVD-2022-4494
Updated
2026-11-03
GitHub AdvisoriesGHSA-m5pm-rgvf-vg22 8.8

Apache OpenMeetings vulnerable to Cross-Site Request Forgery

Apache OpenMeetings 1.0.0 is vulnerable to Cross-Site Request Forgery (CSRF) attacks, XSS attacks, click-jacking, and MIME based attacks. The issue is fixed in version 3.3.0.

Record
GHSA-m5pm-rgvf-vg22
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSV 8.8

Apache OpenMeetings 1.0.0 is vulnerable to Cross-Site Request Forgery (CSRF) attacks, XSS attacks, click-jacking, and MIME based attacks.

Record
CVE-2017-7666
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-m5pm-rgvf-vg22 8.8

Apache OpenMeetings vulnerable to Cross-Site Request Forgery

Apache OpenMeetings 1.0.0 is vulnerable to Cross-Site Request Forgery (CSRF) attacks, XSS attacks, click-jacking, and MIME based attacks. The issue is fixed in version 3.3.0.

Record
GHSA-m5pm-rgvf-vg22
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.openmeetings:openmeetings-parent
Maven
1.0.0 up to 3.3.0
3.3.0
org.apache.openmeetings:openmeetings-parent
Maven
1.0.0 up to 3.3.0, plus listed versions
3.1.23.1.33.1.43.1.53.2.03.2.1
3.3.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-7666 is a high vulnerability (CVSS 8.8) in Apache Openmeetings, published July 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.80%, the 56th percentile. Fixed in org.apache.openmeetings:openmeetings-parent 3.3.0.

References

MoveEnter Open