Every CVE Search/ Get API key

CVE-2017-7672

Apache Struts Improper Input Validation vulnerability

5.9 MediumFix available

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

9.84%Up 5.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.9

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

Record
CVE-2017-7672
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

Record
CVE-2017-7672
Updated
2026-11-02
EUVDEUVD-2018-0563 No score

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

Record
EUVD-2018-0563
Updated
2026-11-03
GitHub AdvisoriesGHSA-9gp7-jvm2-r4mx 5.9

Apache Struts Improper Input Validation vulnerability

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

Record
GHSA-9gp7-jvm2-r4mx
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV 5.9

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

Record
CVE-2017-7672
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-9gp7-jvm2-r4mx 5.9

Apache Struts Improper Input Validation vulnerability

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

Record
GHSA-9gp7-jvm2-r4mx
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.struts:struts2-core
Maven
2.5.0 up to 2.5.12
2.5.12
org.apache.struts:struts2-core
Maven
2.5.0 up to 2.5.12, plus listed versions
2.52.5.12.5.102.5.10.12.5.22.5.52.5.8
2.5.12

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-7672 is a medium vulnerability (CVSS 5.9) in Apache Struts, published July 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 9.84%, the 95th percentile. Fixed in org.apache.struts:struts2-core 2.5.12.

References

Show 6 moreShow less
MoveEnter Open