CVE-2017-7688
Apache OpenMeetings updates user password in insecure manner
Apache OpenMeetings 1.0.0 updates user password in insecure manner.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
Apache OpenMeetings 1.0.0 updates user password in insecure manner.
- Record
CVE-2017-7688- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Updated
- 2026-11-02
CVE List No score
Apache OpenMeetings 1.0.0 updates user password in insecure manner.
- Record
CVE-2017-7688- Updated
- 2026-11-02
EUVDEUVD-2022-5799 No score
Apache OpenMeetings 1.0.0 updates user password in insecure manner.
- Record
EUVD-2022-5799- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xhj7-jr45-5w8r
7.5
Apache OpenMeetings updates user password in insecure manner
Apache OpenMeetings 1.0.0 updates user password in insecure manner. This issue is fixed in version 3.3.0.
- Record
GHSA-xhj7-jr45-5w8r- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSV
7.5
Apache OpenMeetings 1.0.0 updates user password in insecure manner.
- Record
CVE-2017-7688- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-xhj7-jr45-5w8r
7.5
Apache OpenMeetings updates user password in insecure manner
Apache OpenMeetings 1.0.0 updates user password in insecure manner. This issue is fixed in version 3.3.0.
- Record
GHSA-xhj7-jr45-5w8r- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.openmeetings:openmeetings-parentMaven |
1.0.0 up to 3.3.0 | 3.3.0 |
org.apache.openmeetings:openmeetings-parentMaven |
1.0.0 up to 3.3.0, plus listed versions 3.1.23.1.33.1.43.1.53.2.03.2.1 |
3.3.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-7688 is a high vulnerability (CVSS 7.5) in Apache Openmeetings, published July 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.97%, the 87th percentile. Fixed in org.apache.openmeetings:openmeetings-parent 3.3.0.