Every CVE Search/ Get API key

CVE-2017-7863

FFmpeg before 2017-02-04 has an out-of-bounds write caused by a heap-based buffer overflow...

9.8 CriticalFix available

FFmpeg before 2017-02-04 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame_common function in libavcodec/pngdec.c.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.56%Up 1.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

FFmpeg before 2017-02-04 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame_common function in libavcodec/pngdec.c.

Record
CVE-2017-7863
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

FFmpeg before 2017-02-04 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame_common function in libavcodec/pngdec.c.

Record
CVE-2017-7863
Updated
2026-11-02
EUVDEUVD-2017-16838 No score

FFmpeg before 2017-02-04 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame_common function in libavcodec/pngdec.c.

Record
EUVD-2017-16838
Updated
2026-11-03
GitHub AdvisoriesGHSA-fwwq-f897-49hp 9.8

FFmpeg before 2017-02-04 has an out-of-bounds write caused by a heap-based buffer overflow...

FFmpeg before 2017-02-04 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame_common function in libavcodec/pngdec.c.

Record
GHSA-fwwq-f897-49hp
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 9.8

FFmpeg before 2017-02-04 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame_common function in libavcodec/pngdec.c.

Record
CVE-2017-7863
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2017-7863 9.8

FFmpeg before 2017-02-04 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame_common function in libavcodec/pngdec.c.

Record
DEBIAN-CVE-2017-7863
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-7863 9.8

FFmpeg before 2017-02-04 has an out-of-bounds write caused by a heap-based buffer overflow related to the decode_frame_common function in libavcodec/pngdec.c.

Record
UBUNTU-CVE-2017-7863
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2017:1532-1 No score

Security update for ffmpeg

ffmpeg was updated to fix the following security issues:

CVE-2016-10191: remote exploitaion results code execution ((bsc#1022921) CVE-2016-10192: remote exploitaion results code execution bsc#1022922) CVE-2017-7866: stack-based buffer overflow (bsc#1034176) CVE-2017-7865: heap-based buffer overflow (bsc#1034177) CVE-2017-7863: heap-based buffer overflow (bsc#1034179) CVE-2016-9561: Huge amount memory allocated, resulting in DoS (bsc#1015120)

Record
openSUSE-SU-2017:1532-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10754-1 No score

ffmpeg-4-4.4-5.2 on GA media

These are all security issues fixed in the ffmpeg-4-4.4-5.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10754-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Debian:12
before 7:3.2.4-1
7:3.2.4-1
ffmpeg
Debian:13
before 7:3.2.4-1
7:3.2.4-1
ffmpeg
Debian:14
before 7:3.2.4-1
7:3.2.4-1
libav
Debian:8
before 6:11.12-1~deb8u5, plus listed versions
6:11.11-1~deb8u16:11.12-1~deb8u16:11.12-1~deb8u26:11.12-1~deb8u36:11.12-1~deb8u4
Show 12 moreShow less
6:11.3-16:11.3-1+deb8u16:11.3-26:11.3-36:11.4-16:11.4-1~deb8u16:11.4-26:11.4-2+x32.16:11.6-1~deb8u16:11.7-1~deb8u16:11.8-1~deb8u16:11.9-1~deb8u1
6:11.12-1~deb8u5
ffmpeg2
SUSE:Package Hub 12 SP1
before 2.8.11-12.1
2.8.11-12.1
ffmpeg-4
openSUSE:Tumbleweed
before 4.4-5.2
4.4-5.2

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-7863 is a critical vulnerability (CVSS 9.8) in Ffmpeg, published April 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.56%, the 85th percentile. Fixed in ffmpeg 7:3.2.4-1.

References

Show 59 moreShow less
MoveEnter Open