CVE-2017-8114
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions...
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions before 1.0.11, 1.1.x before 1.1.9, and 1.2.x before 1.2.5. The problem is caused by an improperly restricted exec call in the virtualmin and sasl drivers of the password plugin.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions before 1.0.11, 1.1.x before 1.1.9, and 1.2.x before 1.2.5. The problem is caused by an improperly restricted exec call in the virtualmin and sasl drivers of the password plugin.
- Record
CVE-2017-8114- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-269
- Updated
- 2026-11-02
CVE List No score
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions before 1.0.11, 1.1.x before 1.1.9, and 1.2.x before 1.2.5. The problem is caused by an improperly restricted exec call in the virtualmin and sasl drivers of the password plugin.
- Record
CVE-2017-8114- Updated
- 2026-11-02
EUVDEUVD-2017-17076 No score
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions before 1.0.11, 1.1.x before 1.1.9, and 1.2.x before 1.2.5. The problem is caused by an improperly restricted exec call in the virtualmin and sasl drivers of the password plugin.
- Record
EUVD-2017-17076- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4p57-8qx3-4cjv
8.8
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions...
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions before 1.0.11, 1.1.x before 1.1.9, and 1.2.x before 1.2.5. The problem is caused by an improperly restricted exec call in the virtualmin and sasl drivers of the password plugin.
- Record
GHSA-4p57-8qx3-4cjv- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVALPINE-CVE-2017-8114
8.8
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions before 1.0.11, 1.1.x before 1.1.9, and 1.2.x before 1.2.5. The problem is caused by an improperly restricted exec call in the virtualmin and sasl drivers of the password plugin.
- Record
ALPINE-CVE-2017-8114- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
8.8
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions before 1.0.11, 1.1.x before 1.1.9, and 1.2.x before 1.2.5. The problem is caused by an improperly restricted exec call in the virtualmin and sasl drivers of the password plugin.
- Record
CVE-2017-8114- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2017-8114
8.8
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions before 1.0.11, 1.1.x before 1.1.9, and 1.2.x before 1.2.5. The problem is caused by an improperly restricted exec call in the virtualmin and sasl drivers of the password plugin.
- Record
DEBIAN-CVE-2017-8114- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-8114
8.8
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions before 1.0.11, 1.1.x before 1.1.9, and 1.2.x before 1.2.5. The problem is caused by an improperly restricted exec call in the virtualmin and sasl drivers of the password plugin.
- Record
UBUNTU-CVE-2017-8114- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0181 No score
Updated roundcubemail packages fix security vulnerability
It was discovered that roundcubemail prior to 1.0.11 contained a vulnerability in the virtualmin and sasl drivers of the password plugin (CVE-2017-8114)
- Record
MGASA-2017-0181- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11303-1 No score
roundcubemail-1.4.11-1.3 on GA media
These are all security issues fixed in the roundcubemail-1.4.11-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11303-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
roundcubemailAlpine:v3.2 |
before 1.1.9-r0 | 1.1.9-r0 |
roundcubemailAlpine:v3.3 |
before 1.1.9-r0 | 1.1.9-r0 |
roundcubemailAlpine:v3.4 |
before 1.2.5-r0 | 1.2.5-r0 |
roundcubemailAlpine:v3.5 |
before 1.2.5-r0 | 1.2.5-r0 |
roundcubeDebian:12 |
before 1.2.3+dfsg.1-4 | 1.2.3+dfsg.1-4 |
roundcubeDebian:13 |
before 1.2.3+dfsg.1-4 | 1.2.3+dfsg.1-4 |
roundcubeDebian:14 |
before 1.2.3+dfsg.1-4 | 1.2.3+dfsg.1-4 |
roundcubeDebian:7 |
before 0.7.2-9+deb7u7, plus listed versions 0.7.2-90.7.2-9+deb7u10.7.2-9+deb7u20.7.2-9+deb7u30.7.2-9+deb7u40.7.2-9+deb7u50.7.2-9+deb7u6 |
0.7.2-9+deb7u7 |
roundcubemailMageia:5 |
before 1.0.11-1.mga5 | 1.0.11-1.mga5 |
roundcubeUbuntu:Pro:16.04:LTS |
before 1.2~beta+dfsg.1-0ubuntu1+esm7, plus listed versions 1.1.1+dfsg.1-21.1.2+dfsg.1-51.1.3+dfsg.1-11.1.4+dfsg.1-11.2~beta+dfsg.1-0ubuntu1 Show 6 moreShow less1.2~beta+dfsg.1-0ubuntu1+esm11.2~beta+dfsg.1-0ubuntu1+esm21.2~beta+dfsg.1-0ubuntu1+esm31.2~beta+dfsg.1-0ubuntu1+esm41.2~beta+dfsg.1-0ubuntu1+esm51.2~beta+dfsg.1-0ubuntu1+esm6 |
1.2~beta+dfsg.1-0ubuntu1+esm7 |
roundcubemailopenSUSE:Tumbleweed From an advisory covering 8 CVEs |
before 1.4.11-1.3 | 1.4.11-1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-8114 is a high vulnerability (CVSS 8.8) in Roundcube Webmail, published April 29, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.47%, the 89th percentile. Fixed in roundcubemail 1.1.9-r0.
References
roundcube.net/news/2017/04/28/security-updates-1.2.5-1.1.9-and-1.0.11
security.gentoo.org/glsa/201707-11
securityfocus.com/bid/98445
github.com/ilsani/rd/tree/master/security-advisories/web/roundcube/cve-2017-8114
nvd.nist.gov/vuln/detail/CVE-2017-8114
github.com/advisories/GHSA-4p57-8qx3-4cjv
Show 21 moreShow less
security.alpinelinux.org/vuln/CVE-2017-8114
security-tracker.debian.org/tracker/CVE-2017-8114
advisories.mageia.org/MGASA-2017-0181.html
bugs.mageia.org/show_bug.cgi?id=20787
suse.com/security/cve/CVE-2017-8114
ubuntu.com/security/CVE-2017-8114
github.com/roundcube/roundcubemail/releases/tag/1.2.5
github.com/roundcube/roundcubemail/commit/6e054a37d13dc3772d0aa454a32d5dc3bdcc7003
github.com/roundcube/roundcubemail/releases/tag/1.1.9
github.com/roundcube/roundcubemail/commit/10b227d70a03e33682aaaa0138e84f9256f3cd50
github.com/roundcube/roundcubemail/releases/tag/1.0.11
github.com/roundcube/roundcubemail/commit/271426429bfbb5b63e6dec91b1e4780e8ef1c67e
cve.org/CVERecord?id=CVE-2017-8114
ubuntu.com/security/notices/USN-8132-1
suse.com/security/cve/CVE-2017-16651
suse.com/security/cve/CVE-2017-6820
suse.com/security/cve/CVE-2018-9846
suse.com/security/cve/CVE-2019-10740
suse.com/security/cve/CVE-2020-12641
suse.com/security/cve/CVE-2020-16145
suse.com/security/cve/CVE-2020-35730