CVE-2017-8419
LAME through 3.99.5 relies on the signed integer data type for values in a WAV or AIFF header,...
LAME through 3.99.5 relies on the signed integer data type for values in a WAV or AIFF header, which allows remote attackers to cause a denial of service (stack-based buffer overflow or heap-based buffer overflow) or possibly have unspecified other impact via a crafted file, as demonstrated by mishandling of num_channels.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
LAME through 3.99.5 relies on the signed integer data type for values in a WAV or AIFF header, which allows remote attackers to cause a denial of service (stack-based buffer overflow or heap-based buffer overflow) or possibly have unspecified other impact via a crafted file, as demonstrated by mishandling of num_channels.
- Record
CVE-2017-8419- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
LAME through 3.99.5 relies on the signed integer data type for values in a WAV or AIFF header, which allows remote attackers to cause a denial of service (stack-based buffer overflow or heap-based buffer overflow) or possibly have unspecified other impact via a crafted file, as demonstrated by mishandling of num_channels.
- Record
CVE-2017-8419- Updated
- 2026-11-02
EUVDEUVD-2017-17370 No score
LAME through 3.99.5 relies on the signed integer data type for values in a WAV or AIFF header, which allows remote attackers to cause a denial of service (stack-based buffer overflow or heap-based buffer overflow) or possibly have unspecified other impact via a crafted file, as demonstrated by mishandling of num_channels.
- Record
EUVD-2017-17370- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fg7v-43m7-5p33
7.8
LAME through 3.99.5 relies on the signed integer data type for values in a WAV or AIFF header,...
LAME through 3.99.5 relies on the signed integer data type for values in a WAV or AIFF header, which allows remote attackers to cause a denial of service (stack-based buffer overflow or heap-based buffer overflow) or possibly have unspecified other impact via a crafted file, as demonstrated by mishandling of num_channels.
- Record
GHSA-fg7v-43m7-5p33- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
7.8
LAME through 3.99.5 relies on the signed integer data type for values in a WAV or AIFF header, which allows remote attackers to cause a denial of service (stack-based buffer overflow or heap-based buffer overflow) or possibly have unspecified other impact via a crafted file, as demonstrated by mishandling of num_channels.
- Record
CVE-2017-8419- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-8419
7.8
LAME through 3.99.5 relies on the signed integer data type for values in a WAV or AIFF header, which allows remote attackers to cause a denial of service (stack-based buffer overflow or heap-based buffer overflow) or possibly have unspecified other impact via a crafted file, as demonstrated by mishandling of num_channels.
- Record
DEBIAN-CVE-2017-8419- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-8419
7.8
LAME through 3.99.5 relies on the signed integer data type for values in a WAV or AIFF header, which allows remote attackers to cause a denial of service (stack-based buffer overflow or heap-based buffer overflow) or possibly have unspecified other impact via a crafted file, as demonstrated by mishandling of num_channels.
- Record
UBUNTU-CVE-2017-8419- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-4780-1 No score
lame vulnerabilities
It was discovered that LAME incorrectly handled certain audio files. A remote attacker could possibly use this issue to cause a denial of service. Eight vulnerabilities (CVE-2015-9099, CVE-2015-9100, CVE-2015-9101, CVE-2017-15018, CVE-2017-11720, CVE-2017-8419, CVE-2017-9412, CVE-2017-15045) only affected Ubuntu 14.04 ESM, two vulnerabilities (CVE-2017-9410 and CVE-2017-9411) only affected Ubuntu 16.04 ESM, and one vulnerability (CVE-2017-15019) affected both Ubuntu 14.04 ESM and Ubuntu 16.04.
- Record
USN-4780-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lameDebian:12 |
before 3.99.5+repack1-7 | 3.99.5+repack1-7 |
lameDebian:13 |
before 3.99.5+repack1-7 | 3.99.5+repack1-7 |
lameDebian:14 |
before 3.99.5+repack1-7 | 3.99.5+repack1-7 |
lameUbuntu:Pro:14.04:LTS |
before 3.99.5+repack1-3ubuntu1+esm2, plus listed versions 3.99.5+repack1-33.99.5+repack1-3ubuntu1 |
3.99.5+repack1-3ubuntu1+esm2 |
lameUbuntu:Pro:14.04:LTS |
before 3.99.5+repack1-3ubuntu1+esm3, plus listed versions 3.99.5+repack1-33.99.5+repack1-3ubuntu13.99.5+repack1-3ubuntu1+esm2 |
3.99.5+repack1-3ubuntu1+esm3 |
lameUbuntu:Pro:16.04:LTS |
before 3.99.5+repack1-9ubuntu0.1~esm2, plus listed versions 3.99.5+repack1-93.99.5+repack1-9build13.99.5+repack1-9ubuntu0.1~esm1 |
3.99.5+repack1-9ubuntu0.1~esm2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-8419 is a high vulnerability (CVSS 7.8) in Lame Project Lame, published May 2, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.52%, the 74th percentile. Fixed in lame 3.99.5+repack1-7.
References
sourceforge.net/p/lame/bugs/458
nvd.nist.gov/vuln/detail/CVE-2017-8419
github.com/advisories/GHSA-fg7v-43m7-5p33
security-tracker.debian.org/tracker/CVE-2017-8419
ubuntu.com/security/CVE-2017-8419
cve.org/CVERecord?id=CVE-2017-8419
Show 12 moreShow less
ubuntu.com/security/notices/USN-4780-1
ubuntu.com/security/CVE-2015-9099
ubuntu.com/security/CVE-2015-9100
ubuntu.com/security/CVE-2015-9101
ubuntu.com/security/CVE-2017-9410
ubuntu.com/security/CVE-2017-9411
ubuntu.com/security/CVE-2017-9412
ubuntu.com/security/CVE-2017-11720
ubuntu.com/security/CVE-2017-13712
ubuntu.com/security/CVE-2017-15018
ubuntu.com/security/CVE-2017-15019
ubuntu.com/security/CVE-2017-15045