Every CVE Search/ Get API key

CVE-2017-8807

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5...

9.1 CriticalFix available

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

4.08%Up 2.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.1

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

Record
CVE-2017-8807
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

Record
CVE-2017-8807
Updated
2026-11-02
EUVDEUVD-2017-17750 No score

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

Record
EUVD-2017-17750
Updated
2026-11-03
GitHub AdvisoriesGHSA-r6hf-gj32-7rc9 9.1

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5...

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

Record
GHSA-r6hf-gj32-7rc9
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Weakness
CWE-119
Updated
2026-11-02
OSVALPINE-CVE-2017-8807 9.1

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

Record
ALPINE-CVE-2017-8807
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSV 9.1

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

Record
CVE-2017-8807
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2017-8807 9.1

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

Record
DEBIAN-CVE-2017-8807
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2017-8807 9.1

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

Record
UBUNTU-CVE-2017-8807
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVMGASA-2017-0435 No score

Updated varnish packages fix security vulnerability

vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects. (CVE-2017-8807)

Record
MGASA-2017-0435
Updated
2026-11-02
OSVUSN-4824-1 No score

varnish vulnerability

It was discovered that Varnish incorrectly handled certain inputs. A remote attacker could possibly use this issue to obtain sensitive information.

Record
USN-4824-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
varnish
Alpine:v3.10
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.11
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.12
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.13
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.14
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.15
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.16
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.17
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.18
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.19
4.1.0 up to 5.2.1-r0
5.2.1-r0
Show 17 moreShow less
Affected packages
PackageAffectedFixed
varnish
Alpine:v3.20
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.21
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.22
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.23
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.24
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.3
4.1.0 up to 4.1.9-r0
4.1.9-r0
varnish
Alpine:v3.4
4.1.0 up to 4.1.9-r0
4.1.9-r0
varnish
Alpine:v3.5
4.1.0 up to 4.1.9-r0
4.1.9-r0
varnish
Alpine:v3.6
4.1.0 up to 4.1.9-r0
4.1.9-r0
varnish
Alpine:v3.7
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.8
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Alpine:v3.9
4.1.0 up to 5.2.1-r0
5.2.1-r0
varnish
Debian:12
before 5.2.1-1
5.2.1-1
varnish
Debian:13
before 5.2.1-1
5.2.1-1
varnish
Debian:9
before 5.0.0-7+deb9u2, plus listed versions
5.0.0-75.0.0-7+deb9u1
5.0.0-7+deb9u2
varnish
Mageia:6
before 5.0.0-3.2.mga6
5.0.0-3.2.mga6
varnish
Ubuntu:Pro:16.04:LTS
before 4.1.1-1ubuntu0.2+esm1, plus listed versions
4.0.3-14.1.0-14.1.0-24.1.1-14.1.1-1ubuntu0.2
4.1.1-1ubuntu0.2+esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-8807 is a critical vulnerability (CVSS 9.1) in Varnish-cache Varnish, published November 15, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.08%, the 90th percentile. Fixed in varnish 5.2.1-r0.

References

Show 9 moreShow less
MoveEnter Open