CVE-2017-8846
The read_stream function in stream.c in liblrzip.so in lrzip 0.631 allows remote attackers to...
The read_stream function in stream.c in liblrzip.so in lrzip 0.631 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted archive.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
The read_stream function in stream.c in liblrzip.so in lrzip 0.631 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted archive.
- Record
CVE-2017-8846- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
The read_stream function in stream.c in liblrzip.so in lrzip 0.631 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted archive.
- Record
CVE-2017-8846- Updated
- 2026-11-02
EUVDEUVD-2017-17788 No score
The read_stream function in stream.c in liblrzip.so in lrzip 0.631 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted archive.
- Record
EUVD-2017-17788- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7qpf-hv34-vvr8
5.5
The read_stream function in stream.c in liblrzip.so in lrzip 0.631 allows remote attackers to...
The read_stream function in stream.c in liblrzip.so in lrzip 0.631 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted archive.
- Record
GHSA-7qpf-hv34-vvr8- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
5.5
The read_stream function in stream.c in liblrzip.so in lrzip 0.631 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted archive.
- Record
CVE-2017-8846- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-8846
5.5
The read_stream function in stream.c in liblrzip.so in lrzip 0.631 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted archive.
- Record
DEBIAN-CVE-2017-8846- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-8846
5.5
The read_stream function in stream.c in liblrzip.so in lrzip 0.631 allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted archive.
- Record
UBUNTU-CVE-2017-8846- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-5171-1 No score
lrzip vulnerabilities
It was discovered that Long Range ZIP incorrectly handled certain specially crafted lrz files. A remote attacker could possibly use this issue to cause a denial of service (crash) or other unspecified impact.
- Record
USN-5171-1- Updated
- 2026-11-02
OSVUSN-5171-2 No score
lrzip vulnerabilities
USN-5171-1 fixed vulnerabilities in Long Range ZIP. This update provides the corresponding updates for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.
Original advisory details:
It was discovered that Long Range ZIP incorrectly handled certain specially crafted lrz files. A remote attacker could possibly use this issue to cause a denial of service (crash) or other unspecified impact.
- Record
USN-5171-2- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lrzipDebian:12 |
before 0.631+git180517-1 | 0.631+git180517-1 |
lrzipDebian:13 |
before 0.631+git180517-1 | 0.631+git180517-1 |
lrzipDebian:14 |
before 0.631+git180517-1 | 0.631+git180517-1 |
lrzipDebian:9 |
before 0.631-1+deb9u1, plus listed versions 0.631-1 |
0.631-1+deb9u1 |
lrzipUbuntu:Pro:14.04:LTS |
before 0.616-1ubuntu0.1~esm1, plus listed versions 0.608-20.616-10.616-1ubuntu0.1~esm |
0.616-1ubuntu0.1~esm1 |
lrzipUbuntu:Pro:16.04:LTS |
before 0.621-1ubuntu0.1~esm1, plus listed versions 0.621-1 |
0.621-1ubuntu0.1~esm1 |
lrzipUbuntu:18.04:LTS |
before 0.631-1+deb9u1build0.18.04.1, plus listed versions 0.631-1 |
0.631-1+deb9u1build0.18.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-8846 is a medium vulnerability (CVSS 5.5) in Debian Linux, published May 8, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in lrzip 0.631+git180517-1.
References
blogs.gentoo.org/ago/2017/05/07/lrzip-use-after-free-in-read_stream-stream-c
github.com/ckolivas/lrzip/issues/71
security.gentoo.org/glsa/202005-01
lists.debian.org/debian-lts-announce/2021/08/msg00001.html
nvd.nist.gov/vuln/detail/CVE-2017-8846
github.com/advisories/GHSA-7qpf-hv34-vvr8
Show 14 moreShow less
security-tracker.debian.org/tracker/CVE-2017-8846
ubuntu.com/security/CVE-2017-8846
ubuntu.com/security/notices/USN-5171-1
cve.org/CVERecord?id=CVE-2017-8846
ubuntu.com/security/notices/USN-5171-2
ubuntu.com/security/CVE-2017-8844
ubuntu.com/security/CVE-2017-9928
ubuntu.com/security/CVE-2017-9929
ubuntu.com/security/CVE-2018-5650
ubuntu.com/security/CVE-2018-5747
ubuntu.com/security/CVE-2018-5786
ubuntu.com/security/CVE-2018-9058
ubuntu.com/security/CVE-2018-10685
ubuntu.com/security/CVE-2018-11496