CVE-2017-8904
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer...
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer (aka guest transfer) operations, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-214.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer (aka guest transfer) operations, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-214.
- Record
CVE-2017-8904- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:L/AC:L/Au:S/C:C/I:C/A:C - Updated
- 2026-11-02
CVE List No score
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer (aka guest transfer) operations, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-214.
- Record
CVE-2017-8904- Updated
- 2026-11-02
EUVDEUVD-2017-17844 No score
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer (aka guest transfer) operations, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-214.
- Record
EUVD-2017-17844- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cpcf-5qpg-m8gh
8.8
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer...
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer (aka guest transfer) operations, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-214.
- Record
GHSA-cpcf-5qpg-m8gh- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVALPINE-CVE-2017-8904
8.8
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer (aka guest transfer) operations, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-214.
- Record
ALPINE-CVE-2017-8904- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
8.8
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer (aka guest transfer) operations, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-214.
- Record
CVE-2017-8904- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-8904
8.8
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer (aka guest transfer) operations, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-214.
- Record
DEBIAN-CVE-2017-8904- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-8904
8.8
Xen through 4.8.x mishandles the "contains segment descriptors" property during GNTTABOP_transfer (aka guest transfer) operations, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-214.
- Record
UBUNTU-CVE-2017-8904- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xenAlpine:v3.10 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.11 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.12 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.13 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.14 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.15 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.16 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.17 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.18 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.19 |
before 4.8.1-r2 | 4.8.1-r2 |
Show 19 moreShow less
| Package | Affected | Fixed |
|---|---|---|
xenAlpine:v3.20 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.21 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.22 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.23 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.24 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.3 |
before 4.6.3-r7 | 4.6.3-r7 |
xenAlpine:v3.4 |
before 4.6.3-r9 | 4.6.3-r9 |
xenAlpine:v3.5 |
before 4.7.2-r1 | 4.7.2-r1 |
xenAlpine:v3.6 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.7 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.8 |
before 4.8.1-r2 | 4.8.1-r2 |
xenAlpine:v3.9 |
before 4.8.1-r2 | 4.8.1-r2 |
xenDebian:12 |
before 4.8.1-1+deb9u1 | 4.8.1-1+deb9u1 |
xenDebian:13 |
before 4.8.1-1+deb9u1 | 4.8.1-1+deb9u1 |
xenDebian:14 |
before 4.8.1-1+deb9u1 | 4.8.1-1+deb9u1 |
xenDebian:7 |
before 4.1.6.lts1-8, plus listed versions 4.1.4-34.1.4-3+deb7u14.1.4-3+deb7u24.1.4-3+deb7u34.1.4-3+deb7u4 Show 14 moreShow less4.1.4-3+deb7u54.1.4-3+deb7u64.1.4-3+deb7u74.1.4-3+deb7u84.1.4-3+deb7u94.1.4-44.1.6.1-1+deb7u14.1.6.lts1-14.1.6.lts1-24.1.6.lts1-34.1.6.lts1-44.1.6.lts1-54.1.6.lts1-64.1.6.lts1-7 |
4.1.6.lts1-8 |
xenDebian:8 |
before 4.4.1-9+deb8u9, plus listed versions 4.4.1-94.4.1-9+deb8u14.4.1-9+deb8u24.4.1-9+deb8u34.4.1-9+deb8u4 Show 4 moreShow less4.4.1-9+deb8u54.4.1-9+deb8u64.4.1-9+deb8u74.4.1-9+deb8u8 |
4.4.1-9+deb8u9 |
xenUbuntu:14.04:LTS |
before 4.4.2-0ubuntu0.14.04.11, plus listed versions 4.3.0-1ubuntu14.3.0-1ubuntu24.3.0-1ubuntu34.3.0-1ubuntu44.3.0-1ubuntu5 Show 20 moreShow less4.4.0-0ubuntu34.4.0-0ubuntu44.4.0-0ubuntu54.4.0-0ubuntu5.14.4.0-0ubuntu5.24.4.1-0ubuntu0.14.04.14.4.1-0ubuntu0.14.04.24.4.1-0ubuntu0.14.04.34.4.1-0ubuntu0.14.04.44.4.1-0ubuntu0.14.04.54.4.1-0ubuntu0.14.04.64.4.2-0ubuntu0.14.04.14.4.2-0ubuntu0.14.04.24.4.2-0ubuntu0.14.04.34.4.2-0ubuntu0.14.04.44.4.2-0ubuntu0.14.04.54.4.2-0ubuntu0.14.04.64.4.2-0ubuntu0.14.04.74.4.2-0ubuntu0.14.04.94.4.2-0ubuntu0.14.04.10 |
4.4.2-0ubuntu0.14.04.11 |
xenUbuntu:16.04:LTS |
before 4.6.5-0ubuntu1.1, plus listed versions 4.5.1-0ubuntu14.5.1-0ubuntu24.6.0-1ubuntu14.6.0-1ubuntu24.6.0-1ubuntu4 Show 4 moreShow less4.6.0-1ubuntu4.14.6.0-1ubuntu4.24.6.0-1ubuntu4.34.6.5-0ubuntu1 |
4.6.5-0ubuntu1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-8904 is a high vulnerability (CVSS 8.8) in Xen, published May 9, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.42%, the 36th percentile. Fixed in xen 4.8.1-r2.