CVE-2017-9031
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability...
CVE-2017-9031 is a critical vulnerability (CVSS 9.8) in Deluge-torrent Deluge, published May 16, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.50%, the 84th percentile. Fixed in deluge 1.3.13+git20161130.48cedf63-3.
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.
- Record
CVE-2017-9031- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.
- Record
CVE-2017-9031- Updated
- 2026-11-02
EUVDEUVD-2017-17971 No score
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.
- Record
EUVD-2017-17971- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fffq-gprj-v9cm
9.8
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability...
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.
- Record
GHSA-fffq-gprj-v9cm- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
9.8
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.
- Record
CVE-2017-9031- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-9031
9.8
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.
- Record
DEBIAN-CVE-2017-9031- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-9031
9.8
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file.
- Record
UBUNTU-CVE-2017-9031- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0449 No score
Updated deluge packages fix security vulnerability
The WebUI component in Deluge before 1.3.15 contains a directory traversal vulnerability involving a request in which the name of the render file is not associated with any template file(CVE-2017-9031).
Updated deluge package adds systemd services required to autostart deluge daemon and web services. Note that these services not enabled by default.
- Record
MGASA-2017-0449- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10713-1 No score
deluge-2.0.3-4.7 on GA media
These are all security issues fixed in the deluge-2.0.3-4.7 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10713-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
delugeDebian:12 |
before 1.3.13+git20161130.48cedf63-3 | 1.3.13+git20161130.48cedf63-3 |
delugeDebian:13 |
before 1.3.13+git20161130.48cedf63-3 | 1.3.13+git20161130.48cedf63-3 |
delugeDebian:14 |
before 1.3.13+git20161130.48cedf63-3 | 1.3.13+git20161130.48cedf63-3 |
delugeDebian:7 |
before 1.3.3-2+nmu1+deb7u2, plus listed versions 1.3.3-2+nmu11.3.3-2+nmu1+deb7u1 |
1.3.3-2+nmu1+deb7u2 |
delugeDebian:8 |
before 1.3.10-3+deb8u1, plus listed versions 1.3.10-3 |
1.3.10-3+deb8u1 |
delugeMageia:5 |
before 1.3.11-1.3.mga5 | 1.3.11-1.3.mga5 |
delugeUbuntu:16.04:LTS |
All versions, plus listed versions 1.3.12-1ubuntu1 |
None known |
delugeopenSUSE:Tumbleweed |
before 2.0.3-4.7 | 2.0.3-4.7 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
securityfocus.com/bid/99099
dev.deluge-torrent.org/wiki/ReleaseNotes/1.3.15
debian.org/security/2017/dsa-3856
bugs.debian.org/862611
git.deluge-torrent.org/deluge/commit?h=1.3-stable&id=41acade01ae88f7b7bbdba308a0886771aa582fd
nvd.nist.gov/vuln/detail/CVE-2017-9031
Show 8 moreShow less
github.com/advisories/GHSA-fffq-gprj-v9cm
security-tracker.debian.org/tracker/CVE-2017-9031
advisories.mageia.org/MGASA-2017-0449.html
bugs.mageia.org/show_bug.cgi?id=20895
openwall.com/lists/oss-security/2017/05/18/9
ubuntu.com/security/CVE-2017-9031
cve.org/CVERecord?id=CVE-2017-9031
suse.com/security/cve/CVE-2017-9031