CVE-2017-9303
Laravel does not properly constrain the host portion of a password-reset URL
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.
- Record
CVE-2017-9303- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.
- Record
CVE-2017-9303- Updated
- 2026-11-02
EUVDEUVD-2022-5147 No score
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.
- Record
EUVD-2022-5147- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rc8x-jrrc-frfv
6.1
Laravel does not properly constrain the host portion of a password-reset URL
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.
- Record
GHSA-rc8x-jrrc-frfv- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
6.1
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.
- Record
CVE-2017-9303- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-rc8x-jrrc-frfv
6.1
Laravel does not properly constrain the host portion of a password-reset URL
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.
- Record
GHSA-rc8x-jrrc-frfv- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
laravel/laravelPackagist |
5.4.0 up to 5.4.22 | 5.4.22 |
illuminate/authPackagist |
5.3.0 to 5.3.31 | None known |
illuminate/authPackagist |
5.4.0 up to 5.4.22 | 5.4.22 |
laravel/frameworkPackagist |
5.3.0 to 5.3.31 | None known |
laravel/frameworkPackagist |
5.4.0 up to 5.4.22 | 5.4.22 |
laravel/laravelPackagist |
5.4.0 up to 5.4.22, plus listed versions v5.4.0v5.4.15v5.4.16v5.4.19v5.4.21v5.4.3v5.4.9 |
5.4.22 |
illuminate/authPackagist |
5.3.0 to 5.3.31, plus listed versions v5.3.0v5.3.16v5.3.23v5.3.4 |
None known |
illuminate/authPackagist |
5.4.0 up to 5.4.22, plus listed versions v5.4.0v5.4.13v5.4.17v5.4.19v5.4.9 |
5.4.22 |
laravel/frameworkPackagist |
5.3.0 to 5.3.31, plus listed versions v5.3.0v5.3.1v5.3.10v5.3.11v5.3.12 Show 27 moreShow lessv5.3.13v5.3.14v5.3.15v5.3.16v5.3.17v5.3.18v5.3.19v5.3.2v5.3.20v5.3.21v5.3.22v5.3.23v5.3.24v5.3.25v5.3.26v5.3.27v5.3.28v5.3.29v5.3.3v5.3.30v5.3.31v5.3.4v5.3.5v5.3.6v5.3.7v5.3.8v5.3.9 |
None known |
laravel/frameworkPackagist |
5.4.0 up to 5.4.22, plus listed versions v5.4.0v5.4.1v5.4.10v5.4.11v5.4.12 Show 17 moreShow lessv5.4.13v5.4.14v5.4.15v5.4.16v5.4.17v5.4.18v5.4.19v5.4.2v5.4.20v5.4.21v5.4.3v5.4.4v5.4.5v5.4.6v5.4.7v5.4.8v5.4.9 |
5.4.22 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-9303 is a medium vulnerability (CVSS 6.1) in Laravel, published May 29, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.96%, the 61st percentile. Fixed in laravel/laravel 5.4.22.
References
laravel-news.com/laravel-5-4-22-is-now-released-and-includes-a-security-fix
securityfocus.com/bid/98776
nvd.nist.gov/vuln/detail/CVE-2017-9303
github.com/laravel/framework/commit/cef10551820530632a86fa6f1306fee95c5cac43
github.com/FriendsOfPHP/security-advisories/blob/master/illuminate/auth/CVE-2017-9303.yaml
github.com/FriendsOfPHP/security-advisories/blob/master/laravel/framework/CVE-2017-9303.yaml
laravel.com/docs/5.4/releases
web.archive.org/web/20171021180417/http://www.securityfocus.com/bid/98776
github.com/advisories/GHSA-rc8x-jrrc-frfv