CVE-2017-9616
In Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in...
In Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in the dissect_mp4_box function in epan/dissectors/file-mp4.c.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
In Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in the dissect_mp4_box function in epan/dissectors/file-mp4.c.
- Record
CVE-2017-9616- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-674
- Updated
- 2026-11-02
CVE List No score
In Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in the dissect_mp4_box function in epan/dissectors/file-mp4.c.
- Record
CVE-2017-9616- Updated
- 2026-11-02
EUVDEUVD-2017-18547 No score
In Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in the dissect_mp4_box function in epan/dissectors/file-mp4.c.
- Record
EUVD-2017-18547- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w848-9v8p-7jfr
5.5
In Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in...
In Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in the dissect_mp4_box function in epan/dissectors/file-mp4.c.
- Record
GHSA-w848-9v8p-7jfr- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-674
- Updated
- 2026-11-02
OSV
5.5
In Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in the dissect_mp4_box function in epan/dissectors/file-mp4.c.
- Record
CVE-2017-9616- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-9616
5.5
In Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in the dissect_mp4_box function in epan/dissectors/file-mp4.c.
- Record
DEBIAN-CVE-2017-9616- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-9616
5.5
In Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in the dissect_mp4_box function in epan/dissectors/file-mp4.c.
- Record
UBUNTU-CVE-2017-9616- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wiresharkDebian:12 |
before 2.4.0-1 | 2.4.0-1 |
wiresharkDebian:13 |
before 2.4.0-1 | 2.4.0-1 |
wiresharkDebian:14 |
before 2.4.0-1 | 2.4.0-1 |
wiresharkUbuntu:14.04:LTS |
before 2.6.3-1~ubuntu14.04.1, plus listed versions 1.10.2-11.10.3-11.10.5-1ubuntu11.10.5-21.10.6-11.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1 |
2.6.3-1~ubuntu14.04.1 |
wiresharkUbuntu:16.04:LTS |
before 2.6.3-1~ubuntu16.04.1, plus listed versions 1.12.7+g7fc8978-11.12.8+g5b6e543-22.0.1+g59ea380-3build12.0.2+ga16e22e-12.2.6+g32dac6a-2ubuntu0.16.04 |
2.6.3-1~ubuntu16.04.1 |
wiresharkUbuntu:18.04:LTS |
before 2.6.3-1~ubuntu18.04.1, plus listed versions 2.4.2-12.4.3-12.4.4-12.4.5-1 |
2.6.3-1~ubuntu18.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-9616 is a medium vulnerability (CVSS 5.5) in Wireshark, published June 14, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.03%, the 63rd percentile. Fixed in wireshark 2.4.0-1.
References
securityfocus.com/bid/99085
securitytracker.com/id/1038706
bugs.wireshark.org/bugzilla/show_bug.cgi?id=13777
nvd.nist.gov/vuln/detail/CVE-2017-9616
github.com/advisories/GHSA-w848-9v8p-7jfr
security-tracker.debian.org/tracker/CVE-2017-9616
ubuntu.com/security/CVE-2017-9616
cve.org/CVERecord?id=CVE-2017-9616