CVE-2017-9765
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used...
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.
- Record
CVE-2017-9765- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-190
- Updated
- 2026-11-02
CVE List No score
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.
- Record
CVE-2017-9765- Updated
- 2026-11-02
EUVDEUVD-2017-18695 No score
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.
- Record
EUVD-2017-18695- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h3gg-c3fx-2m67
8.1
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used...
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.
- Record
GHSA-h3gg-c3fx-2m67- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSV
8.1
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.
- Record
CVE-2017-9765- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2017-9765
8.1
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.
- Record
DEBIAN-CVE-2017-9765- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-9765
8.1
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x before 2.8.48, as used on Axis cameras and other devices, allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow and application crash) via a large XML document, aka Devil's Ivy. NOTE: the large document would be blocked by many common web-server configurations on general-purpose computers.
- Record
UBUNTU-CVE-2017-9765- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2017-0221 No score
Updated gsoap packages fix security vulnerability
A potential vulnerability to a large and specific XML message over 2GB in size (greater than 2147483711 bytes to trigger the software bug). A buffer overflow can cause an open unsecured server to crash or malfunction after 2GB is received (CVE-2017-9765).
- Record
MGASA-2017-0221- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10825-1 No score
gsoap-devel-2.8.117-1.2 on GA media
These are all security issues fixed in the gsoap-devel-2.8.117-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10825-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gsoapDebian:12 |
before 2.8.48-1 | 2.8.48-1 |
gsoapDebian:13 |
before 2.8.48-1 | 2.8.48-1 |
gsoapDebian:14 |
before 2.8.48-1 | 2.8.48-1 |
r-other-x4rDebian:12 |
before 1.0.1+git20150806.c6bd9bd-2 | 1.0.1+git20150806.c6bd9bd-2 |
r-other-x4rDebian:13 |
before 1.0.1+git20150806.c6bd9bd-2 | 1.0.1+git20150806.c6bd9bd-2 |
r-other-x4rDebian:14 |
before 1.0.1+git20150806.c6bd9bd-2 | 1.0.1+git20150806.c6bd9bd-2 |
gsoapDebian:7 |
before 2.8.7-2+deb7u1, plus listed versions 2.8.7-2 |
2.8.7-2+deb7u1 |
gsoapMageia:5 |
before 2.8.49-1.mga5 | 2.8.49-1.mga5 |
gsoapMageia:6 |
before 2.8.49-1.mga6 | 2.8.49-1.mga6 |
gsoapUbuntu:16.04:LTS |
All versions, plus listed versions 2.8.22-12.8.22-22.8.28-1 |
None known |
gsoapopenSUSE:Tumbleweed |
before 2.8.117-1.2 | 2.8.117-1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-9765 is a high vulnerability (CVSS 8.1) in Genivia Gsoap, published July 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 42.1%, the 98th percentile. Fixed in gsoap 2.8.48-1.
References
bugzilla.suse.com/show_bug.cgi?id=1049348
blog.senr.io/blog/devils-ivy-flaw-in-widely-used-third-party-code-impacts-millions
blog.senr.io/devilsivy.html
genivia.com/advisory.html
bugzilla.redhat.com/show_bug.cgi?id=1472807
securityfocus.com/bid/99868
Show 10 moreShow less
genivia.com/changelog.html
nvd.nist.gov/vuln/detail/CVE-2017-9765
github.com/advisories/GHSA-h3gg-c3fx-2m67
security-tracker.debian.org/tracker/CVE-2017-9765
advisories.mageia.org/MGASA-2017-0221.html
bugs.mageia.org/show_bug.cgi?id=21298
openwall.com/lists/oss-security/2017/07/19/7
ubuntu.com/security/CVE-2017-9765
cve.org/CVERecord?id=CVE-2017-9765
suse.com/security/cve/CVE-2017-9765