Every CVE Search/ Get API key

CVE-2017-9787

Spring AOP functionality (Struts) vulnerable to DoS attack

7.5 HighFix available

When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

10.6%Up 5.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.

Record
CVE-2017-9787
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.

Record
CVE-2017-9787
Updated
2026-11-02
EUVDEUVD-2018-0551 No score

When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.

Record
EUVD-2018-0551
Updated
2026-11-03
GitHub AdvisoriesGHSA-8mr5-h28g-36qx 7.5

Spring AOP functionality (Struts) vulnerable to DoS attack

When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.

Record
GHSA-8mr5-h28g-36qx
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.

Record
CVE-2017-9787
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-8mr5-h28g-36qx 7.5

Spring AOP functionality (Struts) vulnerable to DoS attack

When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.

Record
GHSA-8mr5-h28g-36qx
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.struts:struts2-core
Maven
2.5.0 up to 2.5.12
2.5.12
org.apache.struts:struts2-core
Maven
2.3.7 up to 2.3.33
2.3.33
org.apache.struts:struts2-core
Maven
2.3.7 up to 2.3.33, plus listed versions
2.3.122.3.142.3.14.12.3.14.22.3.14.3
Show 21 moreShow less
2.3.152.3.15.12.3.15.22.3.15.32.3.162.3.16.12.3.16.22.3.16.32.3.202.3.20.12.3.20.32.3.242.3.24.12.3.24.32.3.282.3.28.12.3.292.3.302.3.312.3.322.3.8
2.3.33
org.apache.struts:struts2-core
Maven
2.5.0 up to 2.5.12, plus listed versions
2.52.5.12.5.102.5.10.12.5.22.5.52.5.8
2.5.12

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-9787 is a high vulnerability (CVSS 7.5) in Apache Struts, published July 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 10.6%, the 95th percentile. Fixed in org.apache.struts:struts2-core 2.5.12.

References

Show 9 moreShow less
MoveEnter Open