CVE-2018-0499
xapian-core Cross-site Scripting vulnerability
A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
- Record
CVE-2018-0499- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
- Record
CVE-2018-0499- Updated
- 2026-11-02
EUVDEUVD-2022-3053 No score
A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
- Record
EUVD-2022-3053- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7qw4-w7hf-22q3
6.1
xapian-core Cross-site Scripting vulnerability
A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
- Record
GHSA-7qw4-w7hf-22q3- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVALPINE-CVE-2018-0499
6.1
A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
- Record
ALPINE-CVE-2018-0499- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSV
6.1
A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
- Record
CVE-2018-0499- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2018-0499
6.1
A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
- Record
DEBIAN-CVE-2018-0499- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-7qw4-w7hf-22q3
6.1
xapian-core Cross-site Scripting vulnerability
A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
- Record
GHSA-7qw4-w7hf-22q3- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-0499
6.1
A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().
- Record
UBUNTU-CVE-2018-0499- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11516-1 No score
libxapian-devel-1.4.18-1.6 on GA media
These are all security issues fixed in the libxapian-devel-1.4.18-1.6 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11516-1- Updated
- 2026-11-02
OSVUSN-3709-1 No score
xapian-core vulnerability
It was discovered that Xapian-core incorrectly handled certain files. An attacker could possibly use this to execute arbitrary code.
- Record
USN-3709-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xapian-coreRubyGems |
before 1.4.6 | 1.4.6 |
xapian-coreAlpine:v3.22 |
before 1.4.6-r0 | 1.4.6-r0 |
xapian-coreAlpine:v3.23 |
before 1.4.6-r0 | 1.4.6-r0 |
xapian-coreAlpine:v3.24 |
before 1.4.6-r0 | 1.4.6-r0 |
xapian-coreDebian:12 |
before 1.4.6-1 | 1.4.6-1 |
xapian-coreDebian:13 |
before 1.4.6-1 | 1.4.6-1 |
xapian-coreDebian:14 |
before 1.4.6-1 | 1.4.6-1 |
xapian-coreRubyGems |
before 1.4.6, plus listed versions 1.2.19.11.2.20.21.2.31.2.3.11.2.7.11.4.2 |
1.4.6 |
xapian-coreUbuntu:18.04:LTS |
before 1.4.5-1ubuntu0.1, plus listed versions 1.4.4-21.4.5-1 |
1.4.5-1ubuntu0.1 |
xapianopenSUSE:Tumbleweed |
before 1.4.18-1.6 | 1.4.18-1.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-0499 is a medium vulnerability (CVSS 6.1) in Xapian Xapian-core, published July 2, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.04%, the 64th percentile. Fixed in xapian-core 1.4.6.