CVE-2018-0733
Incorrect CRYPTO_memcmp on HP-UX PA-RISC
Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.9
Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).
- Record
CVE-2018-0733- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
Incorrect CRYPTO_memcmp on HP-UX PA-RISC
Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).
- Record
CVE-2018-0733- Updated
- 2026-11-02
EUVDEUVD-2018-1543 No score
Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).
- Record
EUVD-2018-1543- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j66x-3v7r-hj5f
5.9
Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to...
Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).
- Record
GHSA-j66x-3v7r-hj5f- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVALPINE-CVE-2018-0733
5.9
Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).
- Record
ALPINE-CVE-2018-0733- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVBELL-CVE-2018-0733
5.9
CVE-2018-0733 does not affect BellSoft software
- Record
BELL-CVE-2018-0733- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSV
5.9
Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).
- Record
CVE-2018-0733- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-0733
5.9
Because of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).
- Record
DEBIAN-CVE-2018-0733- CVSS 3.0
- 5.9 Medium
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
opensslAlpine:v3.3 |
1.1.0 up to 1.0.2o-r0 | 1.0.2o-r0 |
opensslAlpine:v3.4 |
1.1.0 up to 1.0.2o-r0 | 1.0.2o-r0 |
opensslAlpine:v3.5 |
1.1.0 up to 1.0.2o-r0 | 1.0.2o-r0 |
opensslAlpine:v3.6 |
1.1.0 up to 1.0.2o-r0 | 1.0.2o-r0 |
opensslAlpine:v3.7 |
1.1.0 up to 1.0.2o-r0 | 1.0.2o-r0 |
opensslAlpine:v3.8 |
1.1.0 up to 1.0.2o-r0 | 1.0.2o-r0 |
opensslDebian:12 |
before 1.1.0h-1 | 1.1.0h-1 |
opensslDebian:13 |
before 1.1.0h-1 | 1.1.0h-1 |
opensslDebian:14 |
before 1.1.0h-1 | 1.1.0h-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-0733 is a medium vulnerability (CVSS 5.9) in Openssl, published March 27, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.28%, the 94th percentile. Fixed in openssl 1.0.2o-r0.
References
tenable.com/security/tns-2018-07
tenable.com/security/tns-2018-04
oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
security.gentoo.org/glsa/201811-21
securityfocus.com/bid/103517
Show 14 moreShow less
tenable.com/security/tns-2018-06
oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
security.netapp.com/advisory/ntap-20180330-0002
securitytracker.com/id/1040576
git.openssl.org/gitweb?p=openssl.git%3Ba=commitdiff%3Bh=56d5a4bfcaf37fa420aef2bb881aa55e61cf5f2f
openssl.org/news/secadv/20180327.txt
oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
nvd.nist.gov/vuln/detail/CVE-2018-0733
git.openssl.org/gitweb?p=openssl.git;a=commitdiff;h=56d5a4bfcaf37fa420aef2bb881aa55e61cf5f2f
github.com/advisories/GHSA-j66x-3v7r-hj5f
security.alpinelinux.org/vuln/CVE-2018-0733
docs.bell-sw.com/security/cves/CVE-2018-0733
security-tracker.debian.org/tracker/CVE-2018-0733