Every CVE Search/ Get API key

CVE-2018-0787

ASP.NET Core allow an elevation of privilege

8.8 HighFix available

ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

9.57%Down 1.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".

Record
CVE-2018-0787
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-640
Updated
2026-11-02
CVE List No score

ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".

Record
CVE-2018-0787
Updated
2026-11-02
EUVDEUVD-2018-0483 No score

ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".

Record
EUVD-2018-0483
Updated
2026-11-03
GitHub AdvisoriesGHSA-365p-96qv-xr7g 8.8

ASP.NET Core allow an elevation of privilege

ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".

Record
GHSA-365p-96qv-xr7g
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-640
Updated
2026-11-02
OSV 8.8

ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".

Record
CVE-2018-0787
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-365p-96qv-xr7g 8.8

ASP.NET Core allow an elevation of privilege

ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".

Record
GHSA-365p-96qv-xr7g
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-640
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
Microsoft.AspNetCore.HttpOverrides
NuGet
2.0.0 to 2.0.1
2.0.2
Microsoft.AspNetCore.Server.Kestrel.Core
NuGet
2.0.0 to 2.0.1
2.0.2
Microsoft.AspNetCore.HttpOverrides
NuGet
2.0.0 up to 2.0.2, plus listed versions
2.0.1
2.0.2
Microsoft.AspNetCore.Server.Kestrel.Core
NuGet
2.0.0 up to 2.0.2, plus listed versions
2.0.1
2.0.2

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-0787 is a high vulnerability (CVSS 8.8) in Microsoft Asp.net Core, published March 14, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 9.57%, the 95th percentile. Fixed in Microsoft.AspNetCore.HttpOverrides 2.0.2.

References

MoveEnter Open