CVE-2018-10001
The decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote...
The decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote attackers to cause a denial of service (out of array read) via an AVI file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
The decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote attackers to cause a denial of service (out of array read) via an AVI file.
- Record
CVE-2018-10001- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
The decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote attackers to cause a denial of service (out of array read) via an AVI file.
- Record
CVE-2018-10001- Updated
- 2026-11-02
EUVDEUVD-2018-2085 No score
The decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote attackers to cause a denial of service (out of array read) via an AVI file.
- Record
EUVD-2018-2085- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wm45-whhp-3jqp
6.5
The decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote...
The decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote attackers to cause a denial of service (out of array read) via an AVI file.
- Record
GHSA-wm45-whhp-3jqp- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
6.5
The decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote attackers to cause a denial of service (out of array read) via an AVI file.
- Record
CVE-2018-10001- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-10001
6.5
The decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote attackers to cause a denial of service (out of array read) via an AVI file.
- Record
DEBIAN-CVE-2018-10001- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-10001
6.5
The decode_init function in libavcodec/utvideodec.c in FFmpeg through 3.4.2 allows remote attackers to cause a denial of service (out of array read) via an AVI file.
- Record
UBUNTU-CVE-2018-10001- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0319 No score
Updated ffmpeg packages fix security vulnerabilities
This update provides ffmpeg version 3.3.8, which fixes several security vulnerabilities and other bugs which were corrected upstream.
- Record
MGASA-2018-0319- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ffmpegDebian:12 |
before 7:3.4.3-1 | 7:3.4.3-1 |
ffmpegDebian:13 |
before 7:3.4.3-1 | 7:3.4.3-1 |
ffmpegDebian:14 |
before 7:3.4.3-1 | 7:3.4.3-1 |
ffmpegDebian:9 |
before 7:3.2.11-1~deb9u1, plus listed versions 7:3.2.10-1~deb9u17:3.2.10-1~deb9u1~bpo8+17:3.2.5-17:3.2.6-17:3.2.7-1~deb9u17:3.2.8-1~deb9u17:3.2.9-1~deb9u1 |
7:3.2.11-1~deb9u1 |
ffmpegMageia:6 |
before 3.3.8-1.mga6 | 3.3.8-1.mga6 |
ffmpegMageia:6 |
before 3.3.8-1.mga6.tainted | 3.3.8-1.mga6.tainted |
ffmpegUbuntu:18.04:LTS |
before 7:3.4.4-0ubuntu0.18.04.1, plus listed versions 7:3.3.4-27:3.3.4-2build37:3.4-2ubuntu27:3.4-47:3.4-4build1 Show 5 moreShow less7:3.4.1-17:3.4.1-1build17:3.4.2-17:3.4.2-1build17:3.4.2-2 |
7:3.4.4-0ubuntu0.18.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-10001 is a medium vulnerability (CVSS 6.5) in Ffmpeg, published April 11, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.30%, the 83rd percentile. Fixed in ffmpeg 7:3.4.3-1.
References
git.videolan.org?p=ffmpeg.git%3Ba=commit%3Bh=47b7c68ae54560e2308bdb6be4fb076c73b93081
debian.org/security/2018/dsa-4249
securityfocus.com/bid/103732
security.gentoo.org/glsa/202003-65
nvd.nist.gov/vuln/detail/CVE-2018-10001
git.videolan.org?p=ffmpeg.git;a=commit;h=47b7c68ae54560e2308bdb6be4fb076c73b93081
Show 9 moreShow less
github.com/advisories/GHSA-wm45-whhp-3jqp
security-tracker.debian.org/tracker/CVE-2018-10001
advisories.mageia.org/MGASA-2018-0319.html
bugs.mageia.org/show_bug.cgi?id=23329
git.ffmpeg.org/gitweb/ffmpeg.git/shortlog/n3.3.8
ffmpeg.org/download.html
ffmpeg.org/security.html
ubuntu.com/security/CVE-2018-10001
cve.org/CVERecord?id=CVE-2018-10001