CVE-2018-1000110
Incorrect Authorization in Jenkins Git Plugin
An improper authorization vulnerability exists in Jenkins Git Plugin version 3.7.0 and earlier in GitStatus.java that allows an attacker with network access to obtain a list of nodes and users.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.3
An improper authorization vulnerability exists in Jenkins Git Plugin version 3.7.0 and earlier in GitStatus.java that allows an attacker with network access to obtain a list of nodes and users.
- Record
CVE-2018-1000110- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
CVE List No score
An improper authorization vulnerability exists in Jenkins Git Plugin version 3.7.0 and earlier in GitStatus.java that allows an attacker with network access to obtain a list of nodes and users.
- Record
CVE-2018-1000110- Updated
- 2026-11-02
EUVDEUVD-2022-2316 No score
An improper authorization vulnerability exists in Jenkins Git Plugin version 3.7.0 and earlier in GitStatus.java that allows an attacker with network access to obtain a list of nodes and users.
- Record
EUVD-2022-2316- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-46p2-fwqg-3h6m
5.3
Incorrect Authorization in Jenkins Git Plugin
An improper authorization vulnerability exists in Jenkins Git Plugin version 3.7.0 and earlier in GitStatus.java that allows an attacker with network access to obtain a list of nodes and users.
- Record
GHSA-46p2-fwqg-3h6m- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
OSV
5.3
An improper authorization vulnerability exists in Jenkins Git Plugin version 3.7.0 and earlier in GitStatus.java that allows an attacker with network access to obtain a list of nodes and users.
- Record
CVE-2018-1000110- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-46p2-fwqg-3h6m
5.3
Incorrect Authorization in Jenkins Git Plugin
An improper authorization vulnerability exists in Jenkins Git Plugin version 3.7.0 and earlier in GitStatus.java that allows an attacker with network access to obtain a list of nodes and users.
- Record
GHSA-46p2-fwqg-3h6m- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jenkins-ci.plugins:gitMaven |
through 3.7.0 | 3.8.0 |
org.jenkins-ci.plugins:gitMaven |
before 3.8.0, plus listed versions 1.2.01.3.01.4.01.5.01.6.0-beta-1 Show 45 moreShow less2.02.0-beta-22.0-beta-32.0.12.0.22.0.32.0.42.1.02.2.02.2.12.2.102.2.112.2.122.2.22.2.32.2.42.2.52.2.62.2.72.2.82.2.92.32.3-beta-12.3-beta-22.3-beta-32.3-beta-42.3.12.3.22.3.32.3.42.3.52.4.02.4.12.4.22.4.32.4.42.5.02.5.0-beta12.5.0-beta22.5.0-beta32.5.0-beta42.5.0-beta52.5.12.5.22.5.3 |
3.8.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-1000110 is a medium vulnerability (CVSS 5.3) in Jenkins Git, published March 13, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.91%, the 90th percentile. Fixed in org.jenkins-ci.plugins:git 3.8.0.
References
Left out here: 36 versions. The JSON record has them.