CVE-2018-1000127
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free...
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
- Record
CVE-2018-1000127- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-190, CWE-667
- Updated
- 2026-11-02
CVE List No score
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
- Record
CVE-2018-1000127- Updated
- 2026-11-02
EUVDEUVD-2018-1850 No score
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
- Record
EUVD-2018-1850- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xfxv-84p3-w8rg
7.5
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free...
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
- Record
GHSA-xfxv-84p3-w8rg- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSV
7.5
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
- Record
CVE-2018-1000127- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-1000127
7.5
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
- Record
DEBIAN-CVE-2018-1000127- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVRHSA-2018:2290
6.5
Red Hat Security Advisory: memcached security update
- Record
RHSA-2018:2290- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-1000127
7.5
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
- Record
UBUNTU-CVE-2018-1000127- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11045-1 No score
memcached-1.6.9-2.3 on GA media
These are all security issues fixed in the memcached-1.6.9-2.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11045-1- Updated
- 2026-11-02
OSVUSN-3601-1 No score
memcached vulnerability
It was discovered that Memcached incorrectly handled reusing certain items. A remote attacker could possibly use this issue to cause Memcached to crash, resulting in a denial of service.
- Record
USN-3601-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
memcachedDebian:12 |
before 1.5.0-1 | 1.5.0-1 |
memcachedDebian:13 |
before 1.5.0-1 | 1.5.0-1 |
memcachedDebian:14 |
before 1.5.0-1 | 1.5.0-1 |
memcachedDebian:7 |
before 1.4.13-0.2+deb7u4, plus listed versions 1.4.13-0.21.4.13-0.2+deb7u11.4.13-0.2+deb7u21.4.13-0.2+deb7u3 |
1.4.13-0.2+deb7u4 |
memcachedDebian:8 From an advisory covering 3 CVEs |
before 1.4.21-1.1+deb8u2, plus listed versions 1.4.21-1.11.4.21-1.1+deb8u1 |
1.4.21-1.1+deb8u2 |
memcachedDebian:9 From an advisory covering 3 CVEs |
before 1.4.33-1+deb9u1, plus listed versions 1.4.33-1 |
1.4.33-1+deb9u1 |
memcachedRed Hat:openstack:10::el7 |
before 0:1.4.39-2.el7ost | 0:1.4.39-2.el7ost |
memcached-debuginfoRed Hat:openstack:10::el7 |
before 0:1.4.39-2.el7ost | 0:1.4.39-2.el7ost |
memcachedUbuntu:14.04:LTS |
before 1.4.14-0ubuntu9.3, plus listed versions 1.4.14-0ubuntu41.4.14-0ubuntu81.4.14-0ubuntu91.4.14-0ubuntu9.11.4.14-0ubuntu9.2 |
1.4.14-0ubuntu9.3 |
memcachedUbuntu:16.04:LTS |
before 1.4.25-2ubuntu1.4, plus listed versions 1.4.24-2ubuntu11.4.25-1ubuntu21.4.25-2ubuntu11.4.25-2ubuntu1.21.4.25-2ubuntu1.3 |
1.4.25-2ubuntu1.4 |
memcachedopenSUSE:Tumbleweed From an advisory covering 4 CVEs |
before 1.6.9-2.3 | 1.6.9-2.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-1000127 is a high vulnerability (CVSS 7.5) in Memcached, published March 13, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.27%, the 83rd percentile. Fixed in memcached 1.5.0-1.
References
access.redhat.com/errata/RHSA-2018:2290
lists.debian.org/debian-lts-announce/2018/03/msg00031.html
github.com/memcached/memcached/commit/a8c4a82787b8b6c256d61bd5c42fb7f92d1bae00
usn.ubuntu.com/3601-1
debian.org/security/2018/dsa-4218
github.com/memcached/memcached/wiki/ReleaseNotes1437
Show 15 moreShow less
github.com/memcached/memcached/issues/271
nvd.nist.gov/vuln/detail/CVE-2018-1000127
github.com/advisories/GHSA-xfxv-84p3-w8rg
security-tracker.debian.org/tracker/CVE-2018-1000127
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=1555064
security.access.redhat.com/data/csaf/v2/advisories/2018/rhsa-2018_2290.json
access.redhat.com/security/cve/CVE-2018-1000127
cve.org/CVERecord?id=CVE-2018-1000127
ubuntu.com/security/CVE-2018-1000127
ubuntu.com/security/notices/USN-3601-1
suse.com/security/cve/CVE-2017-9951
suse.com/security/cve/CVE-2018-1000115
suse.com/security/cve/CVE-2018-1000127
suse.com/security/cve/CVE-2020-10931