Every CVE Search/ Get API key

CVE-2018-1000164

Gunicorn contains Improper Neutralization of CRLF sequences in HTTP headers

7.5 HighFix available

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

2.37%Up 1.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Record
CVE-2018-1000164
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-93
Updated
2026-11-02
CVE List No score

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Record
CVE-2018-1000164
Updated
2026-11-02
EUVDEUVD-2018-0076 No score

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Record
EUVD-2018-0076
Updated
2026-11-03
GitHub AdvisoriesGHSA-32pc-xphx-q4f6 8.7

Gunicorn contains Improper Neutralization of CRLF sequences in HTTP headers

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Record
GHSA-32pc-xphx-q4f6
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-93
Updated
2026-11-02
OSV 7.5

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Record
CVE-2018-1000164
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2018-1000164 7.5

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Record
DEBIAN-CVE-2018-1000164
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-32pc-xphx-q4f6 8.7

Gunicorn contains Improper Neutralization of CRLF sequences in HTTP headers

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Record
GHSA-32pc-xphx-q4f6
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-93
Updated
2026-11-02
OSVUBUNTU-CVE-2018-1000164 7.5

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Record
UBUNTU-CVE-2018-1000164
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVPYSEC-2018-55 No score

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

Record
PYSEC-2018-55
Updated
2026-11-02
OSVUSN-4022-1 No score

Gunicorn vulnerability

It was discovered that gunicorn improperly handled certain input. An attacker could potentially use this issue execute a cross-site scripting (XSS) attack.

Record
USN-4022-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gunicorn
PyPI
before 19.5.0
19.5.0
gunicorn
Debian:12
before 19.5.0-1
19.5.0-1
gunicorn
Debian:13
before 19.5.0-1
19.5.0-1
gunicorn
Debian:14
before 19.5.0-1
19.5.0-1
gunicorn
Debian:7
before 0.14.5-3+deb7u2, plus listed versions
0.14.5-3+deb7u1
0.14.5-3+deb7u2
gunicorn
Debian:8
before 19.0-1+deb8u1, plus listed versions
19.0-1
19.0-1+deb8u1
gunicorn
PyPI
before 19.5.0, plus listed versions
0.10.10.00.10.10.11.00.11.1
Show 45 moreShow less
0.11.20.12.00.12.10.12.20.13.00.13.10.13.20.13.30.13.40.14.00.14.10.14.20.14.30.14.40.14.50.14.60.15.00.16.00.16.10.17.00.17.10.17.20.17.30.17.40.20.2.10.30.3.10.3.20.40.4.10.4.20.50.5.10.60.6.10.6.20.6.30.6.40.6.50.6.60.7.00.7.10.7.20.8.0
19.5.0
gunicorn
Ubuntu:Pro:14.04:LTS
before 17.5-2ubuntu0.1~esm1, plus listed versions
17.5-217.5-2build1
17.5-2ubuntu0.1~esm1
gunicorn
Ubuntu:16.04:LTS
before 19.4.5-1ubuntu1.1, plus listed versions
19.0-8ubuntu119.4.1-1ubuntu119.4.5-1ubuntu1
19.4.5-1ubuntu1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-1000164 is a high vulnerability (CVSS 7.5) in Gunicorn, published April 18, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.37%, the 83rd percentile. Fixed in gunicorn 19.5.0.

References

Show 8 moreShow less
This page doesn't list everything

Left out here: 17 versions. The JSON record has them.

MoveEnter Open