CVE-2018-1000179
A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void...
A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void CoreAuthHandler::handle(const Login &msg) coreauthhandler.cpp line 235 that allows an attacker to cause a denial of service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void CoreAuthHandler::handle(const Login &msg) coreauthhandler.cpp line 235 that allows an attacker to cause a denial of service.
- Record
CVE-2018-1000179- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-476
- Updated
- 2026-11-02
CVE List No score
A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void CoreAuthHandler::handle(const Login &msg) coreauthhandler.cpp line 235 that allows an attacker to cause a denial of service.
- Record
CVE-2018-1000179- Updated
- 2026-11-02
EUVDEUVD-2018-1872 No score
A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void CoreAuthHandler::handle(const Login &msg) coreauthhandler.cpp line 235 that allows an attacker to cause a denial of service.
- Record
EUVD-2018-1872- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6mrg-x4pw-vhr6
7.5
A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void...
A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void CoreAuthHandler::handle(const Login &msg) coreauthhandler.cpp line 235 that allows an attacker to cause a denial of service.
- Record
GHSA-6mrg-x4pw-vhr6- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
OSV
7.5
A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void CoreAuthHandler::handle(const Login &msg) coreauthhandler.cpp line 235 that allows an attacker to cause a denial of service.
- Record
CVE-2018-1000179- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-1000179
7.5
A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void CoreAuthHandler::handle(const Login &msg) coreauthhandler.cpp line 235 that allows an attacker to cause a denial of service.
- Record
DEBIAN-CVE-2018-1000179- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2018-1000179
7.5
A NULL Pointer Dereference of CWE-476 exists in quassel version 0.12.4 in the quasselcore void CoreAuthHandler::handle(const Login &msg) coreauthhandler.cpp line 235 that allows an attacker to cause a denial of service.
- Record
UBUNTU-CVE-2018-1000179- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0243 No score
Updated quassel packages fix security vulnerabilities
A heap corruption exists in quassel version 0.12.4 in quasselcore that allows an attacker to execute code remotely (CVE-2018-1000178).
A NULL Pointer Dereference exists in quassel version 0.12.4 in the quasselcore that allows an atacker to denial of service by attempting a login when the database is not initialized (CVE-2018-1000179).
The Mageia 5 package has been patched to fix these issues and the Mageia 6 package has been upgraded to version 0.12.5, which also has other fixes and improvements.
- Record
MGASA-2018-0243- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11291-1 No score
quassel-base-0.13.1-4.10 on GA media
These are all security issues fixed in the quassel-base-0.13.1-4.10 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11291-1- Updated
- 2026-11-02
OSVUSN-4594-1 No score
quassel vulnerabilities
It was discovered that Quassel incorrectly handled Qdatastream protocol. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2018-1000178)
It was discovered that Quassel incorrectly handled certain login requests. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2018-1000179)
- Record
USN-4594-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
quasselDebian:12 |
before 1:0.12.5-1 | 1:0.12.5-1 |
quasselDebian:13 |
before 1:0.12.5-1 | 1:0.12.5-1 |
quasselDebian:14 |
before 1:0.12.5-1 | 1:0.12.5-1 |
quasselDebian:8 From an advisory covering 2 CVEs |
before 1:0.10.0-2.3+deb8u4, plus listed versions 1:0.10.0-2.31:0.10.0-2.3+deb8u11:0.10.0-2.3+deb8u21:0.10.0-2.3+deb8u3 |
1:0.10.0-2.3+deb8u4 |
quasselDebian:9 From an advisory covering 2 CVEs |
before 1:0.12.4-2+deb9u1, plus listed versions 1:0.12.4-2 |
1:0.12.4-2+deb9u1 |
quasselMageia:5 From an advisory covering 2 CVEs |
before 0.10.1-5.3.mga5 | 0.10.1-5.3.mga5 |
quasselMageia:6 From an advisory covering 2 CVEs |
before 0.12.5-1.mga6 | 0.12.5-1.mga6 |
quasselUbuntu:14.04:LTS |
before 0.10.0-0ubuntu2.3, plus listed versions 0.9.1-0ubuntu10.9.2-0ubuntu10.9.2-0ubuntu20.9.2-0ubuntu30.9.2-0ubuntu4 Show 6 moreShow less0.10~beta1-0ubuntu10.10~rc1-0ubuntu10.10.0-0ubuntu10.10.0-0ubuntu20.10.0-0ubuntu2.10.10.0-0ubuntu2.2 |
0.10.0-0ubuntu2.3 |
quasselUbuntu:16.04:LTS |
All versions, plus listed versions 0.12.2-0ubuntu10.12.2-0ubuntu1.16.04.2 |
None known |
quasselUbuntu:18.04:LTS |
before 1:0.12.4-3ubuntu1.18.04.3, plus listed versions 1:0.12.4-2ubuntu21:0.12.4-2ubuntu31:0.12.4-3ubuntu11:0.12.4-3ubuntu1.18.04.11:0.12.4-3ubuntu1.18.04.2 |
1:0.12.4-3ubuntu1.18.04.3 |
quasselUbuntu:18.04:LTS From an advisory covering 2 CVEs |
before 1:0.12.4-3ubuntu1.18.04.3, plus listed versions 1:0.12.4-2ubuntu21:0.12.4-2ubuntu31:0.12.4-3ubuntu11:0.12.4-3ubuntu1.18.04.11:0.12.4-3ubuntu1.18.04.2 |
1:0.12.4-3ubuntu1.18.04.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-1000179 is a high vulnerability (CVSS 7.5) in Quassel-irc Quassel, published May 2, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.28%, the 83rd percentile. Fixed in quassel 1:0.12.5-1.
References
debian.org/security/2018/dsa-4189
security.gentoo.org/glsa/201806-04
github.com/quassel/quassel/blob/master/src/core/coreauthhandler.cpp
usn.ubuntu.com/4594-1
nvd.nist.gov/vuln/detail/CVE-2018-1000179
github.com/advisories/GHSA-6mrg-x4pw-vhr6
Show 14 moreShow less
security-tracker.debian.org/tracker/CVE-2018-1000179
advisories.mageia.org/MGASA-2018-0243.html
bugs.mageia.org/show_bug.cgi?id=22957
openwall.com/lists/oss-security/2018/05/01/1
quassel-irc.org/node/130
ubuntu.com/security/CVE-2018-1000179
github.com/quassel/quassel/commit/e17fca767d60c06ca02bc5898ced04f06d3670bd
github.com/quassel/quassel/commit/08bace4e9ecf08273f094c0c6aa8b3363d38ac3e
openwall.com/lists/oss-security/2018/04/27/1
ubuntu.com/security/notices/USN-4594-1
cve.org/CVERecord?id=CVE-2018-1000179
ubuntu.com/security/CVE-2018-1000178
suse.com/security/cve/CVE-2018-1000178
suse.com/security/cve/CVE-2018-1000179