Every CVE Search/ Get API key

CVE-2018-1000529

Stored Cross Site Scripting in Grails Fields Plugin

6.1 MediumPublic exploitFix available

Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in Using the display tag that can result in XSS . This vulnerability appears to have been fixed in 2.2.8.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.14%Down 1.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in Using the display tag that can result in XSS . This vulnerability appears to have been fixed in 2.2.8.

Record
CVE-2018-1000529
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in Using the display tag that can result in XSS . This vulnerability appears to have been fixed in 2.2.8.

Record
CVE-2018-1000529
Updated
2026-11-02
EUVDEUVD-2018-0655 No score

Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in Using the display tag that can result in XSS . This vulnerability appears to have been fixed in 2.2.8.

Record
EUVD-2018-0655
Updated
2026-11-03
GitHub AdvisoriesGHSA-q25j-gcmv-5qpp 6.1

Stored Cross Site Scripting in Grails Fields Plugin

Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in using the display tag that can result in XSS. This vulnerability has been fixed in version 2.2.8.

Record
GHSA-q25j-gcmv-5qpp
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-q25j-gcmv-5qpp 6.1

Stored Cross Site Scripting in Grails Fields Plugin

Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in using the display tag that can result in XSS. This vulnerability has been fixed in version 2.2.8.

Record
GHSA-q25j-gcmv-5qpp
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.grails.plugins:fields
Maven
before 2.2.8
2.2.8
org.grails:grails-core
Maven
before 3.3.6
3.3.6
org.grails:grails-core
Maven
before 3.3.6, plus listed versions
1.11.1-RC11.1-RC21.1-beta11.1-beta2
Show 45 moreShow less
1.1-beta31.1.11.1.21.2-M21.2-M31.2-M41.2.01.2.0.RC11.2.0.RC21.2.11.2.21.2.31.2.41.2.51.3.01.3.0.RC11.3.0.RC21.3.11.3.21.3.31.3.41.3.51.3.61.3.72.0.12.0.22.0.32.0.42.1.02.1.0.RC12.1.0.RC22.1.0.RC32.1.12.1.22.1.32.1.42.1.52.2.02.2.0.RC12.2.0.RC22.2.0.RC32.2.0.RC42.2.12.2.22.2.3
3.3.6

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubmartinfrancois/CVE-2018-10005292018-05-21

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-1000529 is a medium vulnerability (CVSS 6.1) in Grails Fields, published June 26, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.14%, the 66th percentile. Fixed in org.grails.plugins:fields 2.2.8.

References

This page doesn't list everything

Left out here: 95 versions. The JSON record has them.

MoveEnter Open