CVE-2018-1000637
zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that...
zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.
- Record
CVE-2018-1000637- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.
- Record
CVE-2018-1000637- Updated
- 2026-11-02
EUVDEUVD-2018-1971 No score
zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.
- Record
EUVD-2018-1971- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-px98-fj37-9hmp
7.8
zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that...
zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.
- Record
GHSA-px98-fj37-9hmp- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
7.8
zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.
- Record
CVE-2018-1000637- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-1000637
7.8
zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.
- Record
DEBIAN-CVE-2018-1000637- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-1000637
7.8
zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.
- Record
UBUNTU-CVE-2018-1000637- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
zutilsDebian:12 |
before 1.7-3 | 1.7-3 |
zutilsDebian:13 |
before 1.7-3 | 1.7-3 |
zutilsDebian:14 |
before 1.7-3 | 1.7-3 |
zutilsDebian:8 |
before 1.3-4+deb8u1, plus listed versions 1.3-4 |
1.3-4+deb8u1 |
zutilsUbuntu:16.04:LTS |
All versions, plus listed versions 1.4-1 |
None known |
zutilsUbuntu:18.04:LTS |
All versions, plus listed versions 1.6-31.6-41.6-51.6-61.7-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-1000637 is a high vulnerability (CVSS 7.8) in Nongnu Zutils, published August 20, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.67%, the 76th percentile. Fixed in zutils 1.7-3.
References
lists.debian.org/debian-lts-announce/2018/09/msg00016.html
bugs.debian.org/904819
lists.nongnu.org/archive/html/zutils-bug/2018-08/msg00000.html
nvd.nist.gov/vuln/detail/CVE-2018-1000637
github.com/advisories/GHSA-px98-fj37-9hmp
security-tracker.debian.org/tracker/CVE-2018-1000637
ubuntu.com/security/CVE-2018-1000637
openwall.com/lists/oss-security/2018/08/05/1
cve.org/CVERecord?id=CVE-2018-1000637