Every CVE Search/ Get API key

CVE-2018-1002101

Kubernetes Arbitrary Command Injection

5.9 MediumFix available

In Kubernetes versions 1.9.0-1.9.9, 1.10.0-1.10.5, and 1.11.0-1.11.1, user input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to command line argument injection.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

4.00%Up 3.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.9

In Kubernetes versions 1.9.0-1.9.9, 1.10.0-1.10.5, and 1.11.0-1.11.1, user input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to command line argument injection.

Record
CVE-2018-1002101
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
EUVDEUVD-2022-1238 5.9

In Kubernetes versions 1.9.0-1.9.9, 1.10.0-1.10.5, and 1.11.0-1.11.1, user input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to command line argument injection.

Record
EUVD-2022-1238
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-wqwf-x5cj-rg56 5.9

Kubernetes Arbitrary Command Injection

In Kubernetes versions 1.9.0-1.9.9, 1.10.0-1.10.5, and 1.11.0-1.11.1, user input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to command line argument injection.

Specific Go Packages Affected

k8s.io/kubernetes/pkg/util/mount

Record
GHSA-wqwf-x5cj-rg56
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-78
Updated
2026-11-02
NVD 5.9

In Kubernetes versions 1.9.0-1.9.9, 1.10.0-1.10.5, and 1.11.0-1.11.1, user input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to command line argument injection.

Record
CVE-2018-1002101
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
OSV 9.8

In Kubernetes versions 1.9.0-1.9.9, 1.10.0-1.10.5, and 1.11.0-1.11.1, user input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to command line argument injection.

Record
CVE-2018-1002101
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-wqwf-x5cj-rg56 5.9

Kubernetes Arbitrary Command Injection

In Kubernetes versions 1.9.0-1.9.9, 1.10.0-1.10.5, and 1.11.0-1.11.1, user input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to command line argument injection.

Specific Go Packages Affected

k8s.io/kubernetes/pkg/util/mount

Record
GHSA-wqwf-x5cj-rg56
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-78
Updated
2026-11-02
OSVGO-2022-0886 No score

Kubernetes Arbitrary Command Injection in k8s.io/kubernetes

Kubernetes Arbitrary Command Injection in k8s.io/kubernetes

Record
GO-2022-0886
Updated
2026-11-02
OSVopenSUSE-SU-2025:15424-1 No score

govulncheck-vulndb-0.0.20250807T150727-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20250807T150727-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15424-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
k8s.io/kubernetes
Go
1.9.0 up to 1.9.10
1.9.10
k8s.io/kubernetes
Go
1.10.0 up to 1.10.6
1.10.6
k8s.io/kubernetes
Go
1.11.0 up to 1.11.2
1.11.2
k8s.io/kubernetes
Go
1.9.0 up to 1.9.10, 1.10.0 up to 1.10.6, 1.11.0 up to 1.11.2
1.9.101.10.61.11.2
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 44 CVEs
before 0.0.20250807T150727-1.1
0.0.20250807T150727-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-1002101 is a medium vulnerability (CVSS 5.9) in Kubernetes, published December 5, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.00%, the 90th percentile. Fixed in k8s.io/kubernetes 1.9.10.

References

Show 45 moreShow less
MoveEnter Open