Every CVE Search/ Get API key

CVE-2018-1002150

Koji hub call does not perform correct access checks

9.1 CriticalFix available

Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

1.66%Up 1.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.1

Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.

Record
CVE-2018-1002150
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-732
Updated
2026-11-02
CVE List No score

Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.

Record
CVE-2018-1002150
Updated
2026-11-02
EUVDEUVD-2018-0085 No score

Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.

Record
EUVD-2018-0085
Updated
2026-11-03
GitHub AdvisoriesGHSA-6mww-xvh7-fq4f 9.3

Koji hub call does not perform correct access checks

Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.

Record
GHSA-6mww-xvh7-fq4f
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-732
Updated
2026-11-02
OSVGHSA-6mww-xvh7-fq4f 9.3

Koji hub call does not perform correct access checks

Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.

Record
GHSA-6mww-xvh7-fq4f
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-732
Updated
2026-11-02
OSVUBUNTU-CVE-2018-1002150 9.1

Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.

Record
UBUNTU-CVE-2018-1002150
CVSS 3.0
9.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVPYSEC-2018-86 No score

Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.

Record
PYSEC-2018-86
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
koji
PyPI
1.12 to 1.12
1.12.1
koji
PyPI
1.13 to 1.13
1.13.1
koji
PyPI
1.14 to 1.14
1.14.1
koji
PyPI
1.15 to 1.15
1.15.1
koji
PyPI
1.15 up to 1.15.1, plus listed versions
1.15.0
1.15.1
koji
PyPI
1.14 up to 1.14.1
1.14.1
koji
PyPI
1.13 up to 1.13.1
1.13.1
koji
PyPI
1.12 up to 1.12.1
1.12.1
koji
PyPI
before 1.15.1, plus listed versions
1.15.0
1.15.1
koji
Ubuntu:16.04:LTS
All versions, plus listed versions
1.10.0-1
None known
koji
Ubuntu:18.04:LTS
All versions, plus listed versions
1.10.0-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-1002150 is a critical vulnerability (CVSS 9.1) in Koji Project Koji, published April 4, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.66%, the 76th percentile. Fixed in koji 1.12.1.

References

Show 4 moreShow less
MoveEnter Open