CVE-2018-1002204
Arbitrary File Write in adm-zip
adm-zip npm library before 0.4.9 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.5
adm-zip npm library before 0.4.9 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
CVE-2018-1002204- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
adm-zip npm library before 0.4.9 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
CVE-2018-1002204- Weakness
- CWE-22
- Updated
- 2026-11-02
EUVDEUVD-2018-0219 No score
adm-zip npm library before 0.4.9 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
EUVD-2018-0219- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3v6h-hqm4-2rg6
5.5
Arbitrary File Write in adm-zip
Versions of adm-zip before 0.4.9 are vulnerable to arbitrary file write when used to extract a specifically crafted archive that contains path traversal filenames (../../file.txt for example).
Recommendation
Update to version 0.4.9 or later.
- Record
GHSA-3v6h-hqm4-2rg6- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
5.5
adm-zip npm library before 0.4.9 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
CVE-2018-1002204- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-3v6h-hqm4-2rg6
5.5
Arbitrary File Write in adm-zip
Versions of adm-zip before 0.4.9 are vulnerable to arbitrary file write when used to extract a specifically crafted archive that contains path traversal filenames (../../file.txt for example).
Recommendation
Update to version 0.4.9 or later.
- Record
GHSA-3v6h-hqm4-2rg6- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVCLSA-2026-1776731784 No score
TuxCare security update for adm-zip (1 CVE)
TuxCare rebuilt adm-zip to address 1 CVE. Fixed in 0.4.4-tuxcare.1.
- Record
CLSA-2026-1776731784- Updated
- 2026-11-02
OSVCLSA-2026-1784596298 No score
TuxCare security update for adm-zip (2 CVEs)
TuxCare rebuilt adm-zip to address 2 CVEs. Fixed in 0.4.7-tuxcare.1.
- Record
CLSA-2026-1784596298- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
adm-zipnpm |
before 0.4.11 | 0.4.11 |
adm-zipTuxCare:npm |
0.4.4-tuxcare.0 up to 0.4.4-tuxcare.1, plus listed versions 0.4.4 |
0.4.4-tuxcare.1 |
adm-zipTuxCare:npm From an advisory covering 2 CVEs |
0.4.7-tuxcare.0 up to 0.4.7-tuxcare.1, plus listed versions 0.4.7 |
0.4.7-tuxcare.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-1002204 is a medium vulnerability (CVSS 5.5) in Adm-zip Project Adm-zip, published July 25, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 13.5%, the 96th percentile. Fixed in adm-zip 0.4.11.