CVE-2018-1002209
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to...
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.5
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
CVE-2018-1002209- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
CVE-2018-1002209- Weakness
- CWE-22
- Updated
- 2026-11-02
EUVDEUVD-2018-2082 No score
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
EUVD-2018-2082- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6f6v-x2xf-m89x
5.5
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to...
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
GHSA-6f6v-x2xf-m89x- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
5.5
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
CVE-2018-1002209- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-1002209
5.5
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
DEBIAN-CVE-2018-1002209- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-1002209
5.5
QuaZIP before 0.7.6 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
- Record
UBUNTU-CVE-2018-1002209- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVMGASA-2018-0362 No score
Updated quazip packages fix security vulnerability
Updated quazip packages fix security vulnerability:
A vulnerability has been found in the way developers have implemented the archive extraction of files. An arbitrary file write vulnerability, that can be achieved using a specially crafted zip archive (affects other archives as well, bzip2, tar,xz, war, cpio, 7z), that holds path traversal filenames. So when the filename gets concatenated to the target extraction directory, the final path ends up outside of the target folder. Of course if an executable or a configuration file is overwritten with a file containing malicious code, the problem can turn into an arbitrary code execution issue quite easily. This affects multiple libraries that lacks of a high level APIs that provide the archive extraction functionality (CVE-2018-1002209).
- Record
MGASA-2018-0362- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libquazipDebian:12 |
before 0.7.6-1 | 0.7.6-1 |
libquazipDebian:13 |
before 0.7.6-1 | 0.7.6-1 |
quazipMageia:6 |
before 0.7.6-1.mga6 | 0.7.6-1.mga6 |
libquazipUbuntu:16.04:LTS |
All versions, plus listed versions 0.7-20.7.1-1 |
None known |
libquazipUbuntu:18.04:LTS |
All versions, plus listed versions 0.7.2-10.7.3-10.7.3-5ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-1002209 is a medium vulnerability (CVSS 5.5) in Quazip, published July 25, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.47%, the 92nd percentile. Fixed in libquazip 0.7.6-1.
References
snyk.io/research/zip-slip-vulnerability
github.com/snyk/zip-slip-vulnerability
github.com/stachenov/quazip/blob/0.7.6/NEWS.txt
github.com/stachenov/quazip/commit/5d2fc16a1976e5bf78d2927b012f67a2ae047a98
nvd.nist.gov/vuln/detail/CVE-2018-1002209
github.com/advisories/GHSA-6f6v-x2xf-m89x
Show 7 moreShow less
security-tracker.debian.org/tracker/CVE-2018-1002209
advisories.mageia.org/MGASA-2018-0362.html
bugs.mageia.org/show_bug.cgi?id=23446
lists.fedoraproject.org/archives/list/[email protected]/thread/TMQZPZKZJRQ6ESHXO5LCLIBYWOJX4HAX
ubuntu.com/security/CVE-2018-1002209
bugzilla.redhat.com/show_bug.cgi?id=1593011
cve.org/CVERecord?id=CVE-2018-1002209