Every CVE Search/ Get API key

CVE-2018-10188

phpMyAdmin CSRF vulnerability allowing arbitrary SQL execution

8.8 HighPublic exploitFix available

CVE-2018-10188 is a high vulnerability (CVSS 8.8) in Phpmyadmin, published April 19, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.06%, the 90th percentile. Fixed in phpmyadmin/phpmyadmin 4.8.0.1.

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

4.06%Down 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Record
CVE-2018-10188
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Record
CVE-2018-10188
Updated
2026-11-02
EUVDEUVD-2022-5295 No score

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Record
EUVD-2022-5295
Updated
2026-11-03
GitHub AdvisoriesGHSA-v6fp-h79x-9rqc 8.8

phpMyAdmin CSRF vulnerability allowing arbitrary SQL execution

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Record
GHSA-v6fp-h79x-9rqc
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSV 8.8

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Record
CVE-2018-10188
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-10188 8.8

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Record
DEBIAN-CVE-2018-10188
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-v6fp-h79x-9rqc 8.8

phpMyAdmin CSRF vulnerability allowing arbitrary SQL execution

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Record
GHSA-v6fp-h79x-9rqc
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSVopenSUSE-SU-2018:1058-1 No score

Security update for phpMyAdmin

This update for phpMyAdmin to version 4.8.0.1 fixes the following issues:

  • CVE-2018-10188: Possible execution of arbitrary SQL statements via manipulated URLs (boo#1090309)

This version also contains a number of upstream changes, improvements, new functions and bug fixes.

Record
openSUSE-SU-2018:1058-1
Updated
2026-11-02
OSVopenSUSE-SU-2018:1059-1 No score

Security update for phpMyAdmin

This update for phpMyAdmin to version 4.8.0.1 fixes the following issues:

  • CVE-2018-10188: Possible execution of arbitrary SQL statements via manipulated URLs (boo#1090309)

This version also contains a number of upstream changes, improvements, new functions and bug fixes.

Record
openSUSE-SU-2018:1059-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11171-1 No score

phpMyAdmin-5.1.1-1.2 on GA media

These are all security issues fixed in the phpMyAdmin-5.1.1-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11171-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin/phpmyadmin
Packagist
4.8 up to 4.8.0.1
4.8.0.1
phpmyadmin
Debian:12
before 4:4.9.1+dfsg1-2
4:4.9.1+dfsg1-2
phpmyadmin
Debian:13
before 4:4.9.1+dfsg1-2
4:4.9.1+dfsg1-2
phpmyadmin
Debian:14
before 4:4.9.1+dfsg1-2
4:4.9.1+dfsg1-2
phpmyadmin/phpmyadmin
Packagist
4.8 up to 4.8.0.1, plus listed versions
4.8.0
4.8.0.1
phpMyAdmin
SUSE:Package Hub 12
before 4.8.0.1-20.1
4.8.0.1-20.1
phpMyAdmin
openSUSE:Tumbleweed
before 5.1.1-1.2
5.1.1-1.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBphpMyAdmin 4.8.0 < 4.8.0-1 - Cross-Site Request Forgery2018-04-23

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

Show 35 moreShow less
MoveEnter Open