CVE-2018-10243
htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause...
htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest header.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest header.
- Record
CVE-2018-10243- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest header.
- Record
CVE-2018-10243- Updated
- 2026-11-02
EUVDEUVD-2018-2317 No score
htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest header.
- Record
EUVD-2018-2317- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8g6p-jgrc-8jmf
9.8
htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause...
htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest header.
- Record
GHSA-8g6p-jgrc-8jmf- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
9.8
htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest header.
- Record
CVE-2018-10243- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-10243
9.8
htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest header.
- Record
DEBIAN-CVE-2018-10243- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-10243
9.8
htp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest header.
- Record
UBUNTU-CVE-2018-10243- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libhtpDebian:12 |
before 1:0.5.28-1 | 1:0.5.28-1 |
libhtpDebian:13 |
before 1:0.5.28-1 | 1:0.5.28-1 |
suricataDebian:13 |
before 1:4.0.0-1 | 1:4.0.0-1 |
suricataDebian:14 |
before 1:4.0.0-1 | 1:4.0.0-1 |
suricataDebian:8 From an advisory covering 2 CVEs |
before 2.0.7-2+deb8u4, plus listed versions 2.0.7-22.0.7-2+deb8u12.0.7-2+deb8u22.0.7-2+deb8u3 |
2.0.7-2+deb8u4 |
htpUbuntu:16.04:LTS |
All versions, plus listed versions 1.19-11.19-2 |
None known |
suricataUbuntu:16.04:LTS |
All versions, plus listed versions 2.0.8-1build12.0.9-12.0.10-12.0.10-22.0.11-13.0-1 |
None known |
htpUbuntu:18.04:LTS |
All versions, plus listed versions 1.19-51.19-6 |
None known |
suricataUbuntu:18.04:LTS |
All versions, plus listed versions 3.2-2ubuntu3 |
None known |
htpUbuntu:20.04:LTS |
All versions, plus listed versions 1.19-7 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
htpUbuntu:22.04:LTS |
All versions, plus listed versions 1.19-8 |
None known |
htpUbuntu:24.04:LTS |
All versions, plus listed versions 1.19-8 |
None known |
htpUbuntu:25.10 |
All versions, plus listed versions 1.19-8 |
None known |
htpUbuntu:26.10 |
All versions, plus listed versions 1.19-8build1 |
None known |
htpUbuntu:26.04:LTS |
All versions, plus listed versions 1.19-81.19-8build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-10243 is a critical vulnerability (CVSS 9.8) in Oisf Libhtp, published April 4, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.26%, the 83rd percentile. Fixed in libhtp 1:0.5.28-1.
References
suricata-ids.org/2018/07/18/suricata-4-0-5-available
lists.debian.org/debian-lts-announce/2019/04/msg00010.html
nvd.nist.gov/vuln/detail/CVE-2018-10243
github.com/advisories/GHSA-8g6p-jgrc-8jmf
security-tracker.debian.org/tracker/CVE-2018-10243
ubuntu.com/security/CVE-2018-10243
cve.org/CVERecord?id=CVE-2018-10243