CVE-2018-10685
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the lzma_decompress_buf...
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the lzma_decompress_buf function of stream.c, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the lzma_decompress_buf function of stream.c, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
CVE-2018-10685- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the lzma_decompress_buf function of stream.c, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
CVE-2018-10685- Updated
- 2026-11-02
EUVDEUVD-2018-2756 No score
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the lzma_decompress_buf function of stream.c, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
EUVD-2018-2756- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mjfq-xmf5-hv6p
9.8
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the lzma_decompress_buf...
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the lzma_decompress_buf function of stream.c, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
GHSA-mjfq-xmf5-hv6p- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
9.8
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the lzma_decompress_buf function of stream.c, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
CVE-2018-10685- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-10685
9.8
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the lzma_decompress_buf function of stream.c, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
DEBIAN-CVE-2018-10685- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-10685
9.8
In Long Range Zip (aka lrzip) 0.631, there is a use-after-free in the lzma_decompress_buf function of stream.c, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact.
- Record
UBUNTU-CVE-2018-10685- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-5171-1 No score
lrzip vulnerabilities
It was discovered that Long Range ZIP incorrectly handled certain specially crafted lrz files. A remote attacker could possibly use this issue to cause a denial of service (crash) or other unspecified impact.
- Record
USN-5171-1- Updated
- 2026-11-02
OSVUSN-5171-2 No score
lrzip vulnerabilities
USN-5171-1 fixed vulnerabilities in Long Range ZIP. This update provides the corresponding updates for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.
Original advisory details:
It was discovered that Long Range ZIP incorrectly handled certain specially crafted lrz files. A remote attacker could possibly use this issue to cause a denial of service (crash) or other unspecified impact.
- Record
USN-5171-2- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lrzipDebian:12 |
before 0.631+git180517-1 | 0.631+git180517-1 |
lrzipDebian:13 |
before 0.631+git180517-1 | 0.631+git180517-1 |
lrzipDebian:14 |
before 0.631+git180517-1 | 0.631+git180517-1 |
lrzipDebian:9 From an advisory covering 13 CVEs |
before 0.631-1+deb9u1, plus listed versions 0.631-1 |
0.631-1+deb9u1 |
lrzipUbuntu:Pro:14.04:LTS |
before 0.616-1ubuntu0.1~esm1, plus listed versions 0.608-20.616-10.616-1ubuntu0.1~esm |
0.616-1ubuntu0.1~esm1 |
lrzipUbuntu:Pro:16.04:LTS |
before 0.621-1ubuntu0.1~esm1, plus listed versions 0.621-1 |
0.621-1ubuntu0.1~esm1 |
lrzipUbuntu:18.04:LTS |
before 0.631-1+deb9u1build0.18.04.1, plus listed versions 0.631-1 |
0.631-1+deb9u1build0.18.04.1 |
lrzipUbuntu:18.04:LTS From an advisory covering 10 CVEs |
before 0.631-1+deb9u1build0.18.04.1, plus listed versions 0.631-1 |
0.631-1+deb9u1build0.18.04.1 |
lrzipUbuntu:Pro:14.04:LTS From an advisory covering 10 CVEs |
before 0.616-1ubuntu0.1~esm1, plus listed versions 0.608-20.616-10.616-1ubuntu0.1~esm |
0.616-1ubuntu0.1~esm1 |
lrzipUbuntu:Pro:16.04:LTS From an advisory covering 10 CVEs |
before 0.621-1ubuntu0.1~esm1, plus listed versions 0.621-1 |
0.621-1ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-10685 is a critical vulnerability (CVSS 9.8) in Long Range Zip Project Range Zip, published May 2, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.40%, the 84th percentile. Fixed in lrzip 0.631+git180517-1.
References
github.com/ckolivas/lrzip/issues/95
lists.debian.org/debian-lts-announce/2021/08/msg00001.html
nvd.nist.gov/vuln/detail/CVE-2018-10685
github.com/advisories/GHSA-mjfq-xmf5-hv6p
security-tracker.debian.org/tracker/CVE-2018-10685
ubuntu.com/security/CVE-2018-10685
Show 12 moreShow less
ubuntu.com/security/notices/USN-5171-1
cve.org/CVERecord?id=CVE-2018-10685
ubuntu.com/security/notices/USN-5171-2
ubuntu.com/security/CVE-2017-8844
ubuntu.com/security/CVE-2017-8846
ubuntu.com/security/CVE-2017-9928
ubuntu.com/security/CVE-2017-9929
ubuntu.com/security/CVE-2018-5650
ubuntu.com/security/CVE-2018-5747
ubuntu.com/security/CVE-2018-5786
ubuntu.com/security/CVE-2018-9058
ubuntu.com/security/CVE-2018-11496