Every CVE Search/ Get API key

CVE-2018-1084

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

7.5 HighFix available

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.11%Up 1.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.5

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

Record
CVE-2018-1084
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
EUVDEUVD-2018-11734 7.5

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

Record
EUVD-2018-11734
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-4gvp-pc33-4ccc 9.8

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

Record
GHSA-4gvp-pc33-4ccc
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-190
Updated
2026-11-02
NVD 7.5

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

Record
CVE-2018-1084
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-190
Updated
2026-11-02
OSV 7.5

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

Record
CVE-2018-1084
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-1084 7.5

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

Record
DEBIAN-CVE-2018-1084
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 7 moreShow less
OSVRHSA-2018:1169 7.5

Red Hat Security Advisory: corosync security update

Record
RHSA-2018:1169
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-1084 7.5

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

Record
UBUNTU-CVE-2018-1084
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0275 No score

Updated corosync packages fix security vulnerability

An integer overflow leading to an out-of-bound read was found in authenticate_nss_2_3() in Corosync. An attacker could craft a malicious packet that would lead to a denial of service (CVE-2018-1084).

Record
MGASA-2018-0275
Updated
2026-11-02
OSVopenSUSE-SU-2024:10695-1 No score

corosync-2.4.5+git70.64010f57-1.2 on GA media

These are all security issues fixed in the corosync-2.4.5+git70.64010f57-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10695-1
Updated
2026-11-02
OSVSUSE-SU-2018:1121-1 No score

Security update for corosync

This update for corosync fixes the following issue:

  • CVE-2018-1084: Integer overflow in totemcrypto:authenticate_nss_2_3() could lead to command execution (bsc#1089346)
  • Providing an empty uid or gid results in coroparse adding uid 0. (bsc#1066585)
  • Fix a problem with configuration file incompatibilities that was causing corosync to not work after upgrading from SLE-11-SP4-HA to SLE-12/15-HA. (bsc#1083561)
Record
SUSE-SU-2018:1121-1
Updated
2026-11-02
OSVSUSE-SU-2018:1130-1 No score

Security update for corosync

This update for corosync provides the following fixes:

  • CVE-2018-1084: Integer overflow in totemcrypto:authenticate_nss_2_3() could lead to command execution (bsc#1089346)
  • Providing an empty uid or gid results in coroparse adding uid 0. (bsc#1066585)
  • Fix a problem that was causing corosync memory to increase on ring breakup. (bsc#1083030)
  • Fix a problem with configuration file incompatibilities that was causing corosync to not work after upgrading from SLE-11-SP4-HA to SLE-12/15-HA. (bsc#1083561)
Record
SUSE-SU-2018:1130-1
Updated
2026-11-02
OSVUSN-4000-1 No score

corosync vulnerability

It was discovered that Corosync incorrectly handled certain requests. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code.

Record
USN-4000-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
corosync
Debian:12
before 2.4.4-1
2.4.4-1
corosync
Debian:13
before 2.4.4-1
2.4.4-1
corosync
Debian:14
before 2.4.4-1
2.4.4-1
corosync
Debian:9
before 2.4.2-3+deb9u1, plus listed versions
2.4.2-32.4.2-3+deb9u1~bpo8+1
2.4.2-3+deb9u1
corosync
Mageia:6
before 2.3.5-2.1.mga6
2.3.5-2.1.mga6
corosync
Red Hat:enterprise_linux:7::server
before 0:2.4.3-2.el7_5.1
0:2.4.3-2.el7_5.1
corosync-debuginfo
Red Hat:enterprise_linux:7::server
before 0:2.4.3-2.el7_5.1
0:2.4.3-2.el7_5.1
corosync-qdevice
Red Hat:enterprise_linux:7::server
before 0:2.4.3-2.el7_5.1
0:2.4.3-2.el7_5.1
corosync-qnetd
Red Hat:enterprise_linux:7::server
before 0:2.4.3-2.el7_5.1
0:2.4.3-2.el7_5.1
corosynclib
Red Hat:enterprise_linux:7::server
before 0:2.4.3-2.el7_5.1
0:2.4.3-2.el7_5.1
Show 7 moreShow less
Affected packages
PackageAffectedFixed
corosynclib-devel
Red Hat:enterprise_linux:7::server
before 0:2.4.3-2.el7_5.1
0:2.4.3-2.el7_5.1
corosync
SUSE:Linux Enterprise High Availability Extension 12 SP3
before 2.3.6-9.13.1
2.3.6-9.13.1
corosync
SUSE:Linux Enterprise Software Development Kit 12 SP3
before 2.3.6-9.13.1
2.3.6-9.13.1
corosync
SUSE:Linux Enterprise High Availability Extension 12 SP2
before 2.3.5-6.23.1
2.3.5-6.23.1
corosync
Ubuntu:16.04:LTS
before 2.3.5-3ubuntu2.3, plus listed versions
2.3.4-0ubuntu12.3.5-32.3.5-3ubuntu12.3.5-3ubuntu22.3.5-3ubuntu2.1
2.3.5-3ubuntu2.3
corosync
Ubuntu:18.04:LTS
before 2.4.3-0ubuntu1.1, plus listed versions
2.4.2-3build12.4.2-3ubuntu12.4.3-0ubuntu1
2.4.3-0ubuntu1.1
corosync
openSUSE:Tumbleweed
before 2.4.5+git70.64010f57-1.2
2.4.5+git70.64010f57-1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-1084 is a high vulnerability (CVSS 7.5) in Corosync, published April 12, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.11%, the 87th percentile. Fixed in corosync 2.4.4-1.

References

Show 21 moreShow less
MoveEnter Open