Every CVE Search/ Get API key

CVE-2018-1086

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST...

4.3 MediumFix available

CVE-2018-1086 is a medium vulnerability (CVSS 4.3) in Redhat Pcs, published April 9, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.92%, the 79th percentile. Fixed in pcs 0.9.164-1.

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

1.92%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 4.3

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

Record
CVE-2018-1086
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2018-11736 4.3

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

Record
EUVD-2018-11736
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-p9pc-vgv7-x9j9 7.5

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST...

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

Record
GHSA-p9pc-vgv7-x9j9
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
NVD 4.3

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

Record
CVE-2018-1086
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-20, CWE-200
Updated
2026-11-02
OSV 7.5

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

Record
CVE-2018-1086
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2018-1086 7.5

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

Record
DEBIAN-CVE-2018-1086
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVRHSA-2018:1060 8.7

Red Hat Security Advisory: pcs security update

Record
RHSA-2018:1060
CVSS 3.0
8.7 HighCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:H
Updated
2026-11-02
OSVRHSA-2018:1927 4.3

Red Hat Security Advisory: pcs security update

Record
RHSA-2018:1927
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2018-1086 4.3

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

Record
UBUNTU-CVE-2018-1086
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUSN-7614-1 No score

pcs vulnerabilities

Cedric Buissart discovered that pcs did not correctly handle certain parameters. An attacker could possibly use this issue to leak sensitive information or elevate their privileges. This issue only affected Ubuntu 16.04 LTS. (CVE-2018-1086)

Ondrej Mular discovered that pcs did not correctly handle Unix socket permissions. An attacker could possibly use this issue to elevate their privileges. This issue only affected Ubuntu 22.04 LTS. (CVE-2022-2735)

It was discovered that pcs did not correctly handle PAM authentication. An attacker could possibly use this issue to bypass authentication mechanisms. This issue only affected Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2022-1049)

It was discovered that pcs did not correctly handle the validation of Node names. An attacker could possibly use this issue to execute a cross-site scripting (XSS) attack. This issue only affected Ubuntu 16.04 LTS. (CVE-2017-2661)

Record
USN-7614-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pcs
Debian:12
before 0.9.164-1
0.9.164-1
pcs
Debian:13
before 0.9.164-1
0.9.164-1
pcs
Debian:14
before 0.9.164-1
0.9.164-1
pcs
Debian:9
before 0.9.155+dfsg-2+deb9u1, plus listed versions
0.9.155+dfsg-2
0.9.155+dfsg-2+deb9u1
pcs
Red Hat:enterprise_linux:7::server
before 0:0.9.162-5.el7_5.1
0:0.9.162-5.el7_5.1
pcs-debuginfo
Red Hat:enterprise_linux:7::server
before 0:0.9.162-5.el7_5.1
0:0.9.162-5.el7_5.1
pcs-snmp
Red Hat:enterprise_linux:7::server
before 0:0.9.162-5.el7_5.1
0:0.9.162-5.el7_5.1
pcs
Red Hat:enterprise_linux:6::server
before 0:0.9.155-3.el6
0:0.9.155-3.el6
pcs-debuginfo
Red Hat:enterprise_linux:6::server
before 0:0.9.155-3.el6
0:0.9.155-3.el6
pcs
Ubuntu:Pro:16.04:LTS
before 0.9.149-1ubuntu1.1+esm1, plus listed versions
0.9.149-10.9.149-1ubuntu10.9.149-1ubuntu1.1
0.9.149-1ubuntu1.1+esm1
pcs
Ubuntu:Pro:20.04:LTS
before 0.10.4-3ubuntu0.1~esm1, plus listed versions
0.10.2-10.10.4-20.10.4-2ubuntu10.10.4-3
0.10.4-3ubuntu0.1~esm1
pcs
Ubuntu:Pro:22.04:LTS
before 0.10.11-2ubuntu3+esm1, plus listed versions
0.10.8-1ubuntu10.10.11-2ubuntu20.10.11-2ubuntu3
0.10.11-2ubuntu3+esm1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 23 moreShow less
MoveEnter Open