Every CVE Search/ Get API key

CVE-2018-10891

Moodle XSS Vulnerability

6.3 MediumFix available

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

2.06%Up 1.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.3

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Record
CVE-2018-10891
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2022-4709 6.3

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Record
EUVD-2022-4709
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-p7v9-gjrh-563x 7.3

Moodle XSS Vulnerability

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Record
GHSA-p7v9-gjrh-563x
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
NVD 7.3

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Record
CVE-2018-10891
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
OSV 7.3

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Record
CVE-2018-10891
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
OSVGHSA-p7v9-gjrh-563x 7.3

Moodle XSS Vulnerability

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Record
GHSA-p7v9-gjrh-563x
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-20
Updated
2026-11-02
OSVUBUNTU-CVE-2018-10891 7.3

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Record
UBUNTU-CVE-2018-10891
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 3.0
6.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
3.5.0 up to 3.5.1
3.5.1
moodle/moodle
Packagist
3.4.0 up to 3.4.4
3.4.4
moodle/moodle
Packagist
3.3.0 up to 3.3.7
3.3.7
moodle/moodle
Packagist
3.2.0 up to 3.2.10
3.2.10
moodle/moodle
Packagist
3.1.0 up to 3.1.13
3.1.13
moodle/moodle
Packagist
3.5.0 up to 3.5.1, plus listed versions
v3.5.0
3.5.1
moodle/moodle
Packagist
3.4.0 up to 3.4.4, plus listed versions
v3.4.0v3.4.1v3.4.2v3.4.3
3.4.4
moodle/moodle
Packagist
3.3.0 up to 3.3.7, plus listed versions
v3.3.0v3.3.1v3.3.2v3.3.3v3.3.4v3.3.5v3.3.6
3.3.7
moodle/moodle
Packagist
3.2.0 up to 3.2.10, plus listed versions
v3.2.0v3.2.1v3.2.2v3.2.3v3.2.4
Show 5 moreShow less
v3.2.5v3.2.6v3.2.7v3.2.8v3.2.9
3.2.10
moodle/moodle
Packagist
3.1.0 up to 3.1.13, plus listed versions
v3.1.0v3.1.1v3.1.10v3.1.11v3.1.12
Show 8 moreShow less
v3.1.2v3.1.3v3.1.4v3.1.5v3.1.6v3.1.7v3.1.8v3.1.9
3.1.13
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-10891 is a medium vulnerability (CVSS 6.3) in [unknown] Moodle, published July 10, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.06%, the 81st percentile. Fixed in moodle/moodle 3.5.1.

References

Show 4 moreShow less
MoveEnter Open