CVE-2018-10900
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a...
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.
- Record
CVE-2018-10900- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
EUVDEUVD-2018-2957
8.8
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.
- Record
EUVD-2018-2957- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6cmp-3578-qc4p
7.8
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a...
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.
- Record
GHSA-6cmp-3578-qc4p- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
NVD
7.8
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.
- Record
CVE-2018-10900- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - CVSS 2.0
- 7.2 High
AV:L/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
7.8
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.
- Record
CVE-2018-10900- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-10900
7.8
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.
- Record
DEBIAN-CVE-2018-10900- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-10900
7.8
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.
- Record
UBUNTU-CVE-2018-10900- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10604-1 No score
NetworkManager-vpnc-1.2.6-4.1 on GA media
These are all security issues fixed in the NetworkManager-vpnc-1.2.6-4.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10604-1- Updated
- 2026-11-02
OSVSUSE-SU-2018:2297-1 No score
Recommended update for NetworkManager-vpnc
This update for NetworkManager-vpnc fixes the following issues:
Security issue fixed:
- CVE-2018-10900: Check configurations that contain newline characters and invalidate them to avoid security attacks (bsc#1101147).
- Record
SUSE-SU-2018:2297-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
network-manager-vpncDebian:12 |
before 1.2.6-1 | 1.2.6-1 |
network-manager-vpncDebian:13 |
before 1.2.6-1 | 1.2.6-1 |
network-manager-vpncDebian:8 |
before 0.9.10.0-1+deb8u1, plus listed versions 0.9.10.0-1 |
0.9.10.0-1+deb8u1 |
network-manager-vpncDebian:9 |
before 1.2.4-4+deb9u1, plus listed versions 1.2.4-4 |
1.2.4-4+deb9u1 |
NetworkManager-vpncSUSE:Linux Enterprise Desktop 12 SP3 |
before 1.0.8-8.4.2 | 1.0.8-8.4.2 |
NetworkManager-vpncSUSE:Linux Enterprise Workstation Extension 12 SP3 |
before 1.0.8-8.4.2 | 1.0.8-8.4.2 |
network-manager-vpncUbuntu:14.04:LTS |
before 0.9.8.6-1ubuntu2.1, plus listed versions 0.9.8.2-1ubuntu10.9.8.6-1ubuntu10.9.8.6-1ubuntu2 |
0.9.8.6-1ubuntu2.1 |
network-manager-vpncUbuntu:16.04:LTS |
before 1.1.93-1ubuntu0.1, plus listed versions 0.9.10.0-1ubuntu11.0.8-1ubuntu11.1.93-1 |
1.1.93-1ubuntu0.1 |
network-manager-vpncUbuntu:18.04:LTS |
before 1.2.4-6ubuntu0.1, plus listed versions 1.2.4-41.2.4-6 |
1.2.4-6ubuntu0.1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Network Manager VPNC 1.2.6 - 'Username' Local Privilege Escalation (Metasploit) | 2018-08-31 |
| Metasploit | Network Manager VPNC Username Privilege Escalation | 2018-07-26 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-10900 is a high vulnerability (CVSS 8.8) in [unknown] Networkmanager-vpnc, published July 23, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.92%, the 90th percentile. Fixed in network-manager-vpnc 1.2.6-1.
References
debian.org/security/2018/dsa-4253
security.gentoo.org/glsa/201808-03
lists.debian.org/debian-lts-announce/2018/07/msg00048.html
exploit-db.com/exploits/45313
pulsesecurity.co.nz/advisories/NM-VPNC-Privesc
gitlab.gnome.org/GNOME/NetworkManager-vpnc/commit/07ac18a32b4
Show 12 moreShow less
bugzilla.novell.com/show_bug.cgi?id=1101147
download.gnome.org/sources/NetworkManager-vpnc/1.2/NetworkManager-vpnc-1.2.6.news
bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10900
nvd.nist.gov/vuln/detail/CVE-2018-10900
github.com/advisories/GHSA-6cmp-3578-qc4p
security-tracker.debian.org/tracker/CVE-2018-10900
suse.com/support/update/announcement/2018/suse-su-20182297-1
bugzilla.suse.com/1101147
suse.com/security/cve/CVE-2018-10900
ubuntu.com/security/CVE-2018-10900
openwall.com/lists/oss-security/2018/07/20
cve.org/CVERecord?id=CVE-2018-10900