CVE-2018-11574
Improper input validation together with an integer overflow in the EAP-TLS protocol...
CVE-2018-11574 is a critical vulnerability (CVSS 9.8) in Point-to-point Protocol Project Protocol, published June 14, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.87%, the 79th percentile. Fixed in ppp 2.4.7-2+3.
Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the refuse-app option are unaffected.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the refuse-app option are unaffected.
- Record
CVE-2018-11574- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-20, CWE-190
- Updated
- 2026-11-02
CVE List
9.8
Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the refuse-app option are unaffected.
- Record
CVE-2018-11574- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
EUVDEUVD-2018-3600
9.8
Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the refuse-app option are unaffected.
- Record
EUVD-2018-3600- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-hx7c-3c6c-mhm3
9.8
Improper input validation together with an integer overflow in the EAP-TLS protocol...
Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the refuse-app option are unaffected.
- Record
GHSA-hx7c-3c6c-mhm3- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-190
- Updated
- 2026-11-02
OSV
9.8
Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the refuse-app option are unaffected.
- Record
CVE-2018-11574- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-11574
9.8
Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the refuse-app option are unaffected.
- Record
DEBIAN-CVE-2018-11574- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-11574
9.8
Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the refuse-app option are unaffected.
- Record
UBUNTU-CVE-2018-11574- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-3810-1 No score
ppp vulnerability
Ivan Gotovchits discovered that ppp incorrectly handled the EAP-TLS protocol. A remote attacker could use this issue to cause ppp to crash, resulting in a denial of service, or possibly bypass authentication.
- Record
USN-3810-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pppDebian:12 |
before 2.4.7-2+3 | 2.4.7-2+3 |
pppDebian:13 |
before 2.4.7-2+3 | 2.4.7-2+3 |
pppDebian:14 |
before 2.4.7-2+3 | 2.4.7-2+3 |
pppUbuntu:14.04:LTS |
before 2.4.5-5.1ubuntu2.3, plus listed versions 2.4.5-5.1ubuntu22.4.5-5.1ubuntu2.12.4.5-5.1ubuntu2.2 |
2.4.5-5.1ubuntu2.3 |
pppUbuntu:16.04:LTS |
before 2.4.7-1+2ubuntu1.16.04.1, plus listed versions 2.4.6-3.1ubuntu12.4.7-1+1ubuntu12.4.7-1+2ubuntu1 |
2.4.7-1+2ubuntu1.16.04.1 |
pppUbuntu:18.04:LTS |
before 2.4.7-2+2ubuntu1.1, plus listed versions 2.4.7-1+2ubuntu12.4.7-1+4ubuntu12.4.7-1+4ubuntu32.4.7-2+1ubuntu12.4.7-2+2ubuntu1 |
2.4.7-2+2ubuntu1.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-02 | created | CVE List, EUVD, GitHub Advisories, NVD, OSV |
References
usn.ubuntu.com/3810-1
openwall.com/lists/oss-security/2018/06/11/1
nvd.nist.gov/vuln/detail/CVE-2018-11574
github.com/advisories/GHSA-hx7c-3c6c-mhm3
security-tracker.debian.org/tracker/CVE-2018-11574
ubuntu.com/security/CVE-2018-11574
nikhef.nl/~janjust/ppp/ppp-2.4.7-eaptls-mppe-1.101.patch
ubuntu.com/security/notices/USN-3810-1
cve.org/CVERecord?id=CVE-2018-11574