Every CVE Search/ Get API key

CVE-2018-11768

user/group information can be corrupted across storing in fsimage and reading back from fsimage

7.5 HighFix available

In Apache Hadoop 3.1.0 to 3.1.1, 3.0.0-alpha1 to 3.0.3, 2.9.0 to 2.9.1, and 2.0.0-alpha to 2.8.4, the user/group information can be corrupted across storing in fsimage and reading back from fsimage.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

6.61%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

In Apache Hadoop 3.1.0 to 3.1.1, 3.0.0-alpha1 to 3.0.3, 2.9.0 to 2.9.1, and 2.0.0-alpha to 2.8.4, the user/group information can be corrupted across storing in fsimage and reading back from fsimage.

Record
CVE-2018-11768
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

In Apache Hadoop 3.1.0 to 3.1.1, 3.0.0-alpha1 to 3.0.3, 2.9.0 to 2.9.1, and 2.0.0-alpha to 2.8.4, the user/group information can be corrupted across storing in fsimage and reading back from fsimage.

Record
CVE-2018-11768
Updated
2026-11-02
EUVDEUVD-2019-0752 No score

In Apache Hadoop 3.1.0 to 3.1.1, 3.0.0-alpha1 to 3.0.3, 2.9.0 to 2.9.1, and 2.0.0-alpha to 2.8.4, the user/group information can be corrupted across storing in fsimage and reading back from fsimage.

Record
EUVD-2019-0752
Updated
2026-11-03
GitHub AdvisoriesGHSA-hx83-rpqf-m267 7.5

user/group information can be corrupted across storing in fsimage and reading back from fsimage

In Apache Hadoop 3.1.0 to 3.1.1, 3.0.0-alpha1 to 3.0.3, 2.9.0 to 2.9.1, and 2.0.0-alpha to 2.8.4, the user/group information can be corrupted across storing in fsimage and reading back from fsimage.

Record
GHSA-hx83-rpqf-m267
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-119
Updated
2026-11-02
OSV 7.5

In Apache Hadoop 3.1.0 to 3.1.1, 3.0.0-alpha1 to 3.0.3, 2.9.0 to 2.9.1, and 2.0.0-alpha to 2.8.4, the user/group information can be corrupted across storing in fsimage and reading back from fsimage.

Record
CVE-2018-11768
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-hx83-rpqf-m267 7.5

user/group information can be corrupted across storing in fsimage and reading back from fsimage

In Apache Hadoop 3.1.0 to 3.1.1, 3.0.0-alpha1 to 3.0.3, 2.9.0 to 2.9.1, and 2.0.0-alpha to 2.8.4, the user/group information can be corrupted across storing in fsimage and reading back from fsimage.

Record
GHSA-hx83-rpqf-m267
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-119
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.hadoop:hadoop-main
Maven
2.2.0 up to 2.8.5
2.8.5
org.apache.hadoop:hadoop-main
Maven
2.9.0 up to 2.9.2
2.9.2
org.apache.hadoop:hadoop-main
Maven
3.0.0 up to 3.1.1
3.1.1
org.apache.hadoop:hadoop-main
Maven
2.2.0 up to 2.8.5, plus listed versions
2.3.02.4.02.4.12.5.02.5.1
Show 20 moreShow less
2.5.22.6.02.6.12.6.22.6.32.6.42.6.52.7.02.7.12.7.22.7.32.7.42.7.52.7.62.7.72.8.02.8.12.8.22.8.32.8.4
2.8.5
org.apache.hadoop:hadoop-main
Maven
2.9.0 up to 2.9.2, plus listed versions
2.9.1
2.9.2
org.apache.hadoop:hadoop-main
Maven
3.0.0 up to 3.1.1, plus listed versions
3.0.13.0.23.0.33.1.0
3.1.1

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-11768 is a high vulnerability (CVSS 7.5) in Apache Hadoop, published October 4, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.61%, the 93rd percentile. Fixed in org.apache.hadoop:hadoop-main 2.8.5.

References

Show 17 moreShow less
MoveEnter Open