Every CVE Search/ Get API key

CVE-2018-11775

Improper Certificate Validation in Apache activemq-client

7.4 HighFix available

CVE-2018-11775 is a high vulnerability (CVSS 7.4) in Apache Activemq, published September 10, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.96%, the 94th percentile. Fixed in org.apache.activemq:activemq-client 5.15.6.

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

6.96%Down 2.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.4

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.

Record
CVE-2018-11775
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.

Record
CVE-2018-11775
Updated
2026-11-02
EUVDEUVD-2018-0638 No score

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.

Record
EUVD-2018-0638
Updated
2026-11-03
GitHub AdvisoriesGHSA-m9w8-v359-9ffr 7.4

Improper Certificate Validation in Apache activemq-client

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.

Record
GHSA-m9w8-v359-9ffr
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-295
Updated
2026-11-02
OSV 7.4

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.

Record
CVE-2018-11775
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2018-11775 7.4

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.

Record
DEBIAN-CVE-2018-11775
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVGHSA-m9w8-v359-9ffr 7.4

Improper Certificate Validation in Apache activemq-client

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.

Record
GHSA-m9w8-v359-9ffr
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-295
Updated
2026-11-02
OSVUBUNTU-CVE-2018-11775 7.4

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.

Record
UBUNTU-CVE-2018-11775
CVSS 3.0
7.4 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVUSN-6910-1 No score

activemq vulnerabilities

Chess Hazlett discovered that Apache ActiveMQ incorrectly handled certain commands. A remote attacker could possibly use this issue to terminate the program, resulting in a denial of service. This issue only affected Ubuntu 16.04 LTS. (CVE-2015-7559)

Peter Stöckli discovered that Apache ActiveMQ incorrectly handled hostname verification. A remote attacker could possibly use this issue to perform a person-in-the-middle attack. This issue only affected Ubuntu 16.04 LTS. (CVE-2018-11775)

Jonathan Gallimore and Colm Ó hÉigeartaigh discovered that Apache ActiveMQ incorrectly handled authentication in certain functions. A remote attacker could possibly use this issue to perform a person-in-the-middle attack. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-13920)

Gregor Tudan discovered that Apache ActiveMQ incorrectly handled LDAP authentication. A remote attacker could possibly use this issue to acquire unauthenticated access. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2021-26117)

It was discovered that Apache ActiveMQ incorrectly handled authentication. A remote attacker could possibly use this issue to run arbitrary code. (CVE-2022-41678)

It was discovered that Apache ActiveMQ incorrectly handled deserialization. A remote attacker could possibly use this issue to run arbitrary shell commands. (CVE-2023-46604)

Record
USN-6910-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.activemq:activemq-client
Maven
before 5.15.6
5.15.6
activemq
Debian:12
before 5.15.6-1
5.15.6-1
activemq
Debian:13
before 5.15.6-1
5.15.6-1
activemq
Debian:9
before 5.14.3-3+deb9u2, plus listed versions
5.14.3-35.14.3-3+deb9u1
5.14.3-3+deb9u2
org.apache.activemq:activemq-client
Maven
before 5.15.6, plus listed versions
5.10.05.10.15.10.25.11.05.11.1
Show 28 moreShow less
5.11.25.11.35.11.45.12.05.12.15.12.25.12.35.13.05.13.15.13.25.13.35.13.45.13.55.14.05.14.15.14.25.14.35.14.45.14.55.15.05.15.15.15.25.15.35.15.45.15.55.8.05.9.05.9.1
5.15.6
activemq
Ubuntu:Pro:16.04:LTS
before 5.13.2+dfsg-2ubuntu0.1~esm1, plus listed versions
5.6.0+dfsg1-4+deb8u1ubuntu15.6.0+dfsg1-55.13.2+dfsg-2
5.13.2+dfsg-2ubuntu0.1~esm1
activemq
Ubuntu:Pro:18.04:LTS
before 5.15.8-2~18.04.1~esm1, plus listed versions
5.14.5-35.15.2-25.15.3-25.15.8-2~18.04
5.15.8-2~18.04.1~esm1
activemq
Ubuntu:Pro:20.04:LTS
before 5.15.11-1ubuntu0.1~esm1, plus listed versions
5.15.10-15.15.11-1
5.15.11-1ubuntu0.1~esm1
activemq
Ubuntu:Pro:22.04:LTS
before 5.16.1-1ubuntu0.1~esm1, plus listed versions
5.16.1-1
5.16.1-1ubuntu0.1~esm1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 31 moreShow less
MoveEnter Open