Every CVE Search/ Get API key

CVE-2018-11777

Improper Authentication in hive:hive-exec

8.1 HighFix available

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

2.30%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.1

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Record
CVE-2018-11777
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0
5.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:N
Updated
2026-11-02
CVE List No score

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Record
CVE-2018-11777
Updated
2026-11-02
EUVDEUVD-2018-0775 No score

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Record
EUVD-2018-0775
Updated
2026-11-03
GitHub AdvisoriesGHSA-rrfq-g5fq-fc9c 8.1

Improper Authentication in hive:hive-exec

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Record
GHSA-rrfq-g5fq-fc9c
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSV 8.1

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Record
CVE-2018-11777
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVGHSA-rrfq-g5fq-fc9c 8.1

Improper Authentication in hive:hive-exec

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Record
GHSA-rrfq-g5fq-fc9c
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.hive:hive-exec
Maven
3.0.0 up to 3.1.1
3.1.1
org.apache.hive:hive-exec
Maven
before 2.3.4
2.3.4
org.apache.hive:hive-exec
Maven
3.0.0 up to 3.1.1, plus listed versions
3.1.0
3.1.1
org.apache.hive:hive-exec
Maven
before 2.3.4, plus listed versions
0.10.00.11.00.12.00.13.00.13.1
Show 20 moreShow less
0.14.00.8.00.8.10.9.01.0.01.0.11.1.01.1.11.2.01.2.11.2.22.0.02.0.12.1.02.1.12.2.02.3.02.3.12.3.22.3.3
2.3.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-11777 is a high vulnerability (CVSS 8.1) in Apache Hive, published November 8, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.30%, the 83rd percentile. Fixed in org.apache.hive:hive-exec 3.1.1.

References

MoveEnter Open